PSoC4 BLE High Current consumption in DeepSleep

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
StCa_2048571
Level 1
Level 1

We are currently designing a BLE 4.2 application using CYBLE212020-01 powered by 3V battery. The SW design was done according to Cypress project examples and AN92584 application. We noticed that the current consumption is as low as expected (15uA) in DeepSleep when the module is Connected and the Notification is enabled (only in this case !), but in the other cases (i.e. Advertising state or Connected without Notification Enable or Not Connected) the current consumption is much higher (about x 1000).

Let me give you more details: my software sets the WDT to wake-up the application from DeepSleep every 200ms to read 1 capacitive button and goes back to DeepSleep if the button is not pressed. Once the BLE module (configured as Peripheral) is connected with its Central device and Notification is enabled, the SW calls the API  CyBle_L2capLeConnectionParamUpdateRequest() to set  the BLE Connection Parameters:

Min Connection Interval 4000ms

Max Connection Interval 4000ms

Connection Timeout 30sec

From this point on the DeepSleep Current consumption falls to only 15uA as said before (with a higher short current peak every 4sec because of the Connection interval, that's normal).

I would like to know if someone can help me to reach this Low Power Consumption also in the other BLE states (Not Connected, Connected without Notification Enabled, Advertising).

Thanks

Stefano 

0 Likes
1 Solution
Yugandhar
Moderator
Moderator
Moderator
1000 replies posted 5 likes given First comment on blog

Hello Stefano,

1. Please refer to the recommendations for implementing the low power mode in section 2.5 Low-Power Implementation in the AN92584.

2. Please make sure that the debugging was disabled in the project to reduce current consumption. In Design Wide Resources Go to "system" view and change the "Debug Select" to GPIO.

3. Please put the GPIO pins to Analog High Z mode whenever pins are not used and can switch back to normal drive mode when pins are used. Please refer to the section 6.3 GPIOs in AN86233.

Could you please share your project so that we can check at our end.

The issue was resolved after following above steps Updated

Thanks,

P Yugandhar.

View solution in original post

0 Likes
2 Replies
Yugandhar
Moderator
Moderator
Moderator
1000 replies posted 5 likes given First comment on blog

Hello Stefano,

1. Please refer to the recommendations for implementing the low power mode in section 2.5 Low-Power Implementation in the AN92584.

2. Please make sure that the debugging was disabled in the project to reduce current consumption. In Design Wide Resources Go to "system" view and change the "Debug Select" to GPIO.

3. Please put the GPIO pins to Analog High Z mode whenever pins are not used and can switch back to normal drive mode when pins are used. Please refer to the section 6.3 GPIOs in AN86233.

Could you please share your project so that we can check at our end.

The issue was resolved after following above steps Updated

Thanks,

P Yugandhar.

0 Likes

Hello Yugandhar,

this is a confidential project, we cannot send the SW to the Community directly, we prefer to send it to you personally.

Couldyou give me your email address ?

Thanks

Stefano

0 Likes