Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

aritr0
Level 1
First like given First reply posted First question asked
Level 1

Hello,

I am using PSoC Creator 4.2 and trying to build my project, but am running into the issue "Unable to find component cy_boot_v5_81". I tried to update update the components,  and in the Component Update Tool I see that my current version of cy_boot is 5.81 (Unknown), and the new version in the program is listed as 5.70. How can I update the new version in the program to 5.81?

I came across this post: https://community.infineon.com/t5/PSoC-Creator-Designer/PSoC-Creator-components-update-not-available...

However, the accepted solution did not work for me. Please let me know how to fix this.

0 Likes
1 Solution
AlenAn14
Moderator
Moderator 100 solutions authored 250 replies posted 250 sign-ins
Moderator

Hi @aritr0 ,

The component version 5.81 is only available in higher versions of the PSoC Creator Software.

For example, in PSoC Creator 4.4 you can observe that the component version supported is till 6.10 for cy_boot component as shown below:

AlenAn14_0-1657863568812.png

 

The project you are using might have been created in a higher version of PSoC Creator than the 4.2 version of the same which you are using.

Please install PSoC Creator 4.3 or higher to use v5.81 component of cy_boot component.

Warm Regards
Alen

View solution in original post

0 Likes
3 Replies
AlenAn14
Moderator
Moderator 100 solutions authored 250 replies posted 250 sign-ins
Moderator

Hi @aritr0 ,

The component version 5.81 is only available in higher versions of the PSoC Creator Software.

For example, in PSoC Creator 4.4 you can observe that the component version supported is till 6.10 for cy_boot component as shown below:

AlenAn14_0-1657863568812.png

 

The project you are using might have been created in a higher version of PSoC Creator than the 4.2 version of the same which you are using.

Please install PSoC Creator 4.3 or higher to use v5.81 component of cy_boot component.

Warm Regards
Alen

0 Likes
aritr0
Level 1
First like given First reply posted First question asked
Level 1

Thank you for the response. I tried updating to 4.3 and I do see the later versions of cy_boot. Somehow this project was originally built on PSoC Creator 4.2 though, and updating leads to further issues. Is there no way to resolve this on 4.2?

0 Likes
AlenAn14
Moderator
Moderator 100 solutions authored 250 replies posted 250 sign-ins
Moderator

Hi @aritr0 ,

Unfortunately the latest version of the components are available only in the latest version of PSoC Creator and the same is not backward compatible.

Warm Regards
Alen