Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Newa
Level 1
Level 1
10 sign-ins 5 questions asked 5 sign-ins

Dear Supports.

 

I am using a PSoC 4000S 48Pin.
I want to set Pin7 to INTP0 and Pin27 to UART interrupt (Enable wakeup from Deep Sleep Mode = Active). When I set the UART interrupt, I cannot set the interrupt for the P0.x port. Why are there conflicts in interrupt settings?

 

Thank you.

1 Solution
MotooTanaka
Level 9
Level 9
Distributor - Marubun (Japan)
Beta tester First comment on KBA 1000 replies posted

Hi,

Cortex-M has interrupt for each Port, and not pin.

So there can be only 1 interrupt for Port 0 (P0).

I imagine that is the reason of the conflict.

Can you move INTP0 to another port, such as P1 ~?

moto

View solution in original post

0 Likes
6 Replies
MotooTanaka
Level 9
Level 9
Distributor - Marubun (Japan)
Beta tester First comment on KBA 1000 replies posted

Hi,

I tried with PSoC Creator with a PSoC 4000S 48pin

001-Pins.JPG

Both Pin 26 and Pin 27 seem to be "n/c".

I also checked the PSoC 4: PSoC 4000S Family Datasheet

in the Pinouts (Page 7, 8), there is no Pin 26, Pin 27 in 48-TQFP list.

So I think that the reason you can not use Pin27 is not component conflict,

but the Pin can not be used from the first place.

moto

 

0 Likes

Thank you very much for trying, moto.


I'm sorry, I was misunderstanding. 48pin is wrong, it is a 24pin PSoC 4000S. A collision error has occurred in a 24-pin PSoC.

I'm sorry, but I'm still waiting for your reply.

0 Likes

Hello.

There is no 24-pin 4100S device (not in latest datasheet).  Please provide orderable part number you intend to use in your design.  This will help us figure out what the issue is.

0 Likes
MotooTanaka
Level 9
Level 9
Distributor - Marubun (Japan)
Beta tester First comment on KBA 1000 replies posted

Hi,

I'm sorry, but I'm still waiting for your reply.

Please don't lock on me 😉

If you provide us enough hints, there are many experts who can help you here in the community.

 

Now returning to your question, if the device is 24 pin, selecting pin 27 must be very difficult.

Which pins are you assigning to UART_tx, UART_rx, and INTP0?

Or it would be very helpful, if you can post your project or sample project

with which we can reproduce your problem in our side.

moto

0 Likes

Dear All.

I'm really sorry.  I took a deep breath and reviewed it.

・ UART_tx: 16Pin (P0.5)
・ UART_rx: 15Pin (P0.4)
・ INTP0: 14Pin (P0.1)

When "Enable wakeup from Deep Sleep Mode" was set for UART with the above settings, a conflict occurred with the interrupt setting of P0.1.

0 Likes
MotooTanaka
Level 9
Level 9
Distributor - Marubun (Japan)
Beta tester First comment on KBA 1000 replies posted

Hi,

Cortex-M has interrupt for each Port, and not pin.

So there can be only 1 interrupt for Port 0 (P0).

I imagine that is the reason of the conflict.

Can you move INTP0 to another port, such as P1 ~?

moto

0 Likes