Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

RideMaker
Level 2
10 replies posted 10 sign-ins 5 replies posted
Level 2

I'm new to PSOC usage.  I have been assigned a completed project to update. It has been compiled for a CYBLE224110-00 MODULE, but I want build and upload it for a CY8CKIT-042 KIT.

I loaded the project and went to device selection, but I only see options for MODULE items and I don't see any options matching anything I could see printed on the KIT.  

Does the KIT have an associated MODULE within it I could select?  What would be the process for bringing up a pre-built PSOC4 project built for a specific PSOC4 BLE MODULE using the CY8CKIT-042 KIT?

0 Likes
1 Solution
Yugandhar
Moderator
Moderator 5 likes given First comment on blog 750 replies posted
Moderator

Hello,

In Device Selector, please select the PSoC4200 Series as shown in attached image. Please check the supported components in CY8CKIT-042 PSoC 4 pioneer kit. And, disable the unsupported components and functions to work.

Thanks,

P Yugandhar. 

View solution in original post

0 Likes
2 Replies
odissey1
Level 9
First comment on KBA 1000 replies posted 750 replies posted
Level 9

RideMaker,

I don't know if this is helpful. To visualize parts and components on the CY8KIT-042 (Creator only) one can use:

KIT-042: annotation component for CY8CKIT-042 Pioneer Kit 

 

In the Device Selection, you should pick CY8C4245AXI-483. I don't believe there is any MODULE selection in Creator.

/odissey1

KIT-042_01a_Default_A.png

0 Likes
Yugandhar
Moderator
Moderator 5 likes given First comment on blog 750 replies posted
Moderator

Hello,

In Device Selector, please select the PSoC4200 Series as shown in attached image. Please check the supported components in CY8CKIT-042 PSoC 4 pioneer kit. And, disable the unsupported components and functions to work.

Thanks,

P Yugandhar. 

0 Likes