Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Anonymous
Not applicable

Hi,

   

I have a BLE Pioneer kit and used EZ-BLE PRoC Modules (with CYBLE-012011-00). Configure the Bluetooth, wrote the basic code and enabled for advertisement. With this, I can see my device in phone (using CYSMART application). This gave us the confidence that this can be used for our customer design and got the CYBLE-012012-10 module (basically same part but uncertified), and connected only VDD, VDDR (Radio), Gnd, XRES, P0_7 and P0_6 wires from the module. Used these connection to program from the Pioneer kit and able to program. After this when I power on (giving power to VDD, VDDR and ground to GND pin of  CYBLE-012012-10 module) with other pins left open - I see it is detected only my phone (with Cysmart app). No matter what I do, it is not seen in any other phone. I used many other google play store apps to sniff the BTLE device and none of them seems to be recognizing this CYBLE-012012-10 module.

   

Problem seems weird and not sure, what I am missing. Can you please help me in isolating the problem? Do I need to put other pins of the module into some specific state?

   

With best regards,

   

Phani.

0 Likes
1 Solution
Anonymous
Not applicable

Thanks Guys. It was solved by adding line "CY_SET_XTND_REG32((void CYFAR *)(CYREG_BLE_BLERD_BB_XO_CAPTRIM), 0x0000BCBC);", - Under CYBLE_EVT_STACK_ON: (in callback function)

   

With best regards,

   

Phani,

View solution in original post

0 Likes
3 Replies
rola_264706
Level 8
Level 8
50 likes received 25 likes received 10 likes received

Please  post  your code so we can determine what the issue is .

0 Likes
Anonymous
Not applicable

Hi,

   

In the other phone, are you using the CySmart App or any other App or the Phone's default bluetooth discovery? Make sure the other phones support BTLE.

   

Regards,

   

- Madhu Sudhan

0 Likes
Anonymous
Not applicable

Thanks Guys. It was solved by adding line "CY_SET_XTND_REG32((void CYFAR *)(CYREG_BLE_BLERD_BB_XO_CAPTRIM), 0x0000BCBC);", - Under CYBLE_EVT_STACK_ON: (in callback function)

   

With best regards,

   

Phani,

0 Likes