Announcements

Equip yourself to optimize PSoc4 MCUs for Evs at the EV Webinar. Click here to register.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

Anonymous
Not applicable

Hi all,

   

I have a server peripheral device and I need to use authenticated pairing with encryption and bonding requirement. I have a code in my device working fine with iOS devices (several HW versions with different OS versions). But with android devices, depending on the OS version, sometimes I have to write the pairing key (Android 4.4.4 and 6.0.1) but with Android 5.0.2 I can connect and bond without writing any key. It's like if the OS jumps over authenticated pairing situation. I don't understand why it is. Any idea?

   

Thanks in advance.

0 Likes
1 Solution
AnjanaM_61
Moderator
Moderator
Moderator
First comment on KBA 5 questions asked First question asked

Hello,

   

This should not have happened. Can you please let me know how you are testing your project? Are you testing with CySmart app or with any other app? Are you sending a authentication request in your project?

   

I am attaching a Bonding example project. Please check it with Android 5.0.2 Cysmart app. You should get a passkey entry request.

   

Thanks,

   

Anjana

View solution in original post

0 Likes
1 Reply
AnjanaM_61
Moderator
Moderator
Moderator
First comment on KBA 5 questions asked First question asked

Hello,

   

This should not have happened. Can you please let me know how you are testing your project? Are you testing with CySmart app or with any other app? Are you sending a authentication request in your project?

   

I am attaching a Bonding example project. Please check it with Android 5.0.2 Cysmart app. You should get a passkey entry request.

   

Thanks,

   

Anjana

0 Likes