Announcements

Equip yourself to optimize PSoc4 MCUs for Evs at the EV Webinar. Click here to register.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

Answer
Level 2
Level 2
10 sign-ins 5 replies posted 5 questions asked

I am trying to measure the current consumption of the chip when starting up and when active. I saw on the PDF this:

Answer_0-1626717013021.png

However, I am not using an evaluation board. I am using only the module. 

Answer_1-1626717117050.png

which pins do I connect to measure the total current consumption?

 

0 Likes
1 Solution
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Hello @Answer 

You can measure the current by connecting positive terminal of the external voltage supply to the positive terminal of the ammeter and the the negative terminal of the ammeter to the VDD of the BLE module. At the same time ensure that the ground of the power supply is connected to the ground of the BLE Module.

Thanks 
Ekta

View solution in original post

0 Likes
3 Replies
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Hello @Answer 

You can measure the current by connecting positive terminal of the external voltage supply to the positive terminal of the ammeter and the the negative terminal of the ammeter to the VDD of the BLE module. At the same time ensure that the ground of the power supply is connected to the ground of the BLE Module.

Thanks 
Ekta

0 Likes
Answer
Level 2
Level 2
10 sign-ins 5 replies posted 5 questions asked

@Ekta  Does it matter which VDD is it? I tried them and I am getting 0 readings.

0 Likes
Ekta
Moderator
Moderator
Moderator
250 solutions authored 100 likes received 250 sign-ins

Any VDD on the BLE module should work. I tried the same at my end and it worked. In case you are still facing the same issue can you share a screenshot/block diagram of the setup you are using for measuring the current.

0 Likes