cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ 4

urchc_1533771
New Contributor II

I found that some of devices that have Bluetooth 4.0 can`t discover or can`t connect to my device but new devices can.

   

How to limit BLE component to 4.0 only ? 

0 Likes
1 Solution
Anonymous
Not applicable

Hi Chaplin,

   

A Bluetooth 4.2 device can communicate with a Bluetooth 4.1 and 4.0 device(back compatible) provided that the 4.2 device does not use any Bluetooth 4.2 features.

   

In PSoC Creator, you can use BLE component(v3.1 and v3.2) which are Bluetooth 4.2 compatible, i.e they support the 4.2 features. 

   

Say you have a CYBLE-222005-00, which is a 4.1 device. Now, you can still use BLE component v3.1 and v3.2. PSoC Creator knows that CYBLE-222005-00 is a 4.1 device and will return an error(and sometimes will not allow) if you try to use 4.2 features. 

   

However if you want to restrict to Bluetooth 4.1, you will have to use older version of BLE Component, version v2.30. It is not recommended to use a older version because later versions have bug fixes and advanced features. To change version of component, right-click on project, select 'Update Components...', select v2.3 under BLE.

View solution in original post

0 Likes
7 Replies
himam_31
Employee

Hello

   

Can you please tell more details of the device. Please give the exact part number.

   

Thanks,

   

Hima

0 Likes
urchc_1533771
New Contributor II

It`s not only one device and see other messages about this issue. This  exist in Android. Because exist many versions on market I can compile with SDK to lowest version that I need. Same way Cypress must provide BLE component that can work with lowest ( 4.0)  version of BLE. May be some variable for compiler #ifdef BLE_4_0 ...

0 Likes
urchc_1533771
New Contributor II

Why nobody answer ? Any Cypress employers saw it ? Problem exist but nobody care about ???

0 Likes
Anonymous
Not applicable

Hi,

   

Can you please ensure that the devices that have Bluetooth 4.0 have BLE also in addition to classic bluetooth. Bluetooth 4.0 does not guarantee that BLE is also present. Our devices can be discovered only by devices that support BLE.

   

Regards,

   

-Madhu

0 Likes
urchc_1533771
New Contributor II

Hi !

   

Please pay attention that I talk not about some device that have a problem. I asked about BLE component in PSOC Creator.

   

You provide it with last version 4.2 but many devices have only 4.0 or 4.1 drivers. Do you have back compatibility to old versions ?

   

I think must be possibility  to limit code to versions of BLE.

   

BTW very soon BLE 5 going to arrive...

0 Likes
Anonymous
Not applicable

Hi Chaplin,

   

A Bluetooth 4.2 device can communicate with a Bluetooth 4.1 and 4.0 device(back compatible) provided that the 4.2 device does not use any Bluetooth 4.2 features.

   

In PSoC Creator, you can use BLE component(v3.1 and v3.2) which are Bluetooth 4.2 compatible, i.e they support the 4.2 features. 

   

Say you have a CYBLE-222005-00, which is a 4.1 device. Now, you can still use BLE component v3.1 and v3.2. PSoC Creator knows that CYBLE-222005-00 is a 4.1 device and will return an error(and sometimes will not allow) if you try to use 4.2 features. 

   

However if you want to restrict to Bluetooth 4.1, you will have to use older version of BLE Component, version v2.30. It is not recommended to use a older version because later versions have bug fixes and advanced features. To change version of component, right-click on project, select 'Update Components...', select v2.3 under BLE.

0 Likes
urchc_1533771
New Contributor II

Thanks, I`l try but as you said in new version was bug fixes and I`l receive it ... 

   

It must be done in component or by variable. As I said very soon you will create BLE5 component and this issue will be VERY actual.

0 Likes