Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
KaSa_1259906
Level 2
Level 2
First like received

Hello,

   

I got this error while trying to compile a project. I am using CY8C4247AZI-M485

   

Error in component: cy_boot. The cy_boot_v4_20 component (cy_boot) is not compatible with the selected device. Please check the component datasheet for details on updating to a compatible component.

   

I was looking around the forum and I found that I have to update my components. I checked and found that my components are updated see attached. Any idea what else I could do?

2 Replies
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Just "compiling" the project will not be enough, you have to "build" your project to re-generate the component's sources.

   

When still in trouble post your complete project so that we all can have a look at all of your settings. To do so, use
Creator->File->Create Workspace Bundle (minimal)
and attach the resulting file.

   

 

   

Bob

0 Likes

Thanks for your reply Bob, I actually build before compile. I started again from scratch ( new project) and I was able to rebuild just fine, Problem solved. 

0 Likes