Announcements

Equip yourself to optimize PSoc4 MCUs for Evs at the EV Webinar. Click here to register.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

Bob_G
Level 1
Level 1
5 questions asked 5 sign-ins First reply posted

I am using a PSoC4000S (Cy8C4024FNI-S412, WLCSP-25 package) and am finding it has a much higher current draw than the data sheet says it should.  I am measuring a current draw of about 130 mA at 3.3V, while the datasheet seems to indicate that the max current draw should be about 6 mA.  The chip gets too hot to be touched.

Has anyone else seen such a high current draw from these microprocessors?  Any suggestions as to what might be causing this?

The program is basically a random number generator, outputting random 1s and 0s at a few kHz.  The current draw is with no load across any out the output pins.

 

Thanks!

 

0 Likes
3 Replies
BiBi_1928986
Level 7
Level 7
500 replies posted 250 replies posted 250 sign-ins

Hello.

Check the connections to Vccd.  It should only be connected to a 0.1uF capacitor and nothing else.  Vccd should measure close to 1.8Volts.  This can be measured across the 0.1uF capacitor.

Check the layout around Vccd too.

BTW, the ball pattern is 0.35mm center-to-center.  Check the layout for this spacing.  Some people made the mistake of using a 0.4mm.

Did you configure the voltage for Vddd in Creator Design Wide Resources for 3.3V?

How is 3.3V generated?  A linear regulator fed from 5V?  Or a switching power supply?

You mentioned high current with no load on output pins.  But what about input pins?  When PSoC is powered from 3.3V and an input pin is driven by a 5V signal, the current has to go somewhere and that somewhere is the PSoC Vddd pin.  Hence you'll measure a higher current than expected.

As you can tell, I'm concentrating on power supply issues since that's the most likely area to cause your high current observations.  I suspect even if you changed s/w to simply toggle 1 GPIO and do nothing else, you'd still see the high current.

Let us know your progress.

0 Likes

Thanks for your suggestions.  Here are answers to your questions and an update on the problem.

Vccd is just attached to the 0.1 uF cap and does measure around 1.8 V.

Ball pattern is 0.35 mm.

It was configured for 3.3 V.

The final application will be battery powered, but right now is tested on an Agilent benchtop power supply.

No input pins are being driven.

We tried flashing another PSoC4000S from a different lot# and found that that had a much more reasonable 3 mA current draw, so maybe we have a bad lot of chips...

0 Likes

Hi.

Thanks for the quick reply.  You've made good progress isolating the issue.

You could also try re-flowing the chip on suspect pcb.  Could just be a bad solder connection (or solder short).

Cypress/Infineon has a service to diagnose bad chips.  If you find a number of bad parts, consider contacting Cypress for this analysis.

Sounds like you've got all the design details worked out.  Bravo!  Good luck with your project.

0 Likes