Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

DaEr_349131
Level 5
Level 5
50 sign-ins 5 comments on KBA First comment on KBA

Hi,

Any reasons why we can't run Cypress Programmer to flash the PSoC 4 series?

it would be a great addition to be able to run it from mac

David

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Cypress Programmer has support for PSoC 4000S, PSoC4100S, PSoC 4100S Plus, and PSoC 4500 product lines and corresponding Cypress kits. Please find the detailed list of supported kits and product families in the Cypress Programmer release notes here: https://www.cypress.com/file/506381/download

I have passed your request to the internal development team to evaluate support for PSoC4L. Thank you for your interest in Cypress Products. For now please make use of PSoC Programmer to flash the device by running it on Parallels in Mac.

Regards,

Dheeraj

View solution in original post

2 Replies
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Cypress Programmer has support for PSoC 4000S, PSoC4100S, PSoC 4100S Plus, and PSoC 4500 product lines and corresponding Cypress kits. Please find the detailed list of supported kits and product families in the Cypress Programmer release notes here: https://www.cypress.com/file/506381/download

I have passed your request to the internal development team to evaluate support for PSoC4L. Thank you for your interest in Cypress Products. For now please make use of PSoC Programmer to flash the device by running it on Parallels in Mac.

Regards,

Dheeraj

Thanks Dheeraj,

We're using the 4200 series a lot as well as the psoc 5L, so support for both would be super!