Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

shlim
Level 4
Level 4
50 replies posted 50 questions asked 100 sign-ins

Hi~

Can I use bluetooth SDK version 5.0 with CYBLE-022001-00?

Because I found PSoC 4 BLE use 4.2 BT Block as BT SDK.

But actually Customer introduce this module as BT 5.0 Compliant to the end customer.

I've already known this module registed as bluetooth 5.1

But our customer concerned about Bluetooth SDK version.

If it cannot be updated as BT 5.0, then they should think about other models.

Many Thanks.

 

Daniel Lim
0 Likes
1 Solution
Yugandhar
Moderator
Moderator
Moderator
1000 replies posted 5 likes given First comment on blog

Hello, 

PSoC devices does not use BTSDK. CYBLE-022001-00 module has been qualified for the 5.1 specification, this means that it supports all erratas upto 5.1. But all the 5.1 features won't be available.

Thanks,

P Yugandhar.

View solution in original post

0 Likes
2 Replies
Yugandhar
Moderator
Moderator
Moderator
1000 replies posted 5 likes given First comment on blog

Hello, 

PSoC devices does not use BTSDK. CYBLE-022001-00 module has been qualified for the 5.1 specification, this means that it supports all erratas upto 5.1. But all the 5.1 features won't be available.

Thanks,

P Yugandhar.

0 Likes

Hi! P Yugandhar

Okay Thank you for your advice

But I wonder that PSoC Creater example block show v4.2 compliant 

Please refer to the attached image file

I thought BT Stack support as version 4.2.

 

 

Daniel Lim
0 Likes