Announcements

Equip yourself to optimize PSoc4 MCUs for Evs at the EV Webinar. Click here to register.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

Anonymous
Not applicable

I have a custom board with CYBLE-012011 module. I am trying to flash the same using kitprog on PSOC 4 BLE pioneer kit. But the kitprog is not able to recognise the target. It says "Unknown Target". I tried updating firmware of kitprog, still no luck. Please help. What could be the show stopper? PFA schematic and images of PCB.

WhatsApp Image 2018-08-05 at 10.02.41 AM.jpeg

0 Likes
1 Solution
Anonymous
Not applicable

Programming with kitprog requires the Reset pin.

Is the Reset pin connected?

View solution in original post

6 Replies
Anonymous
Not applicable

There are two kinds of KitProg.

It is KitProg and KitProg2.

These are different things, which are you using?

0 Likes
Anonymous
Not applicable

I'm using the CY*CKIT-042-BLE Pioneer baseboard to flash my custom PCB.

0 Likes
Anonymous
Not applicable

I am using CY8CKIT-042-BLE pioneer kit to flash my board. I'm using jumper wires to connect the SWD pins to my board.

⁣---

Regards,

T N RAJ VIGNESH,

SALIEABS Electronics Engineers LLP.​

0 Likes
Anonymous
Not applicable

Programming with kitprog requires the Reset pin.

Is the Reset pin connected?

Anonymous
Not applicable

No. It is not. But on the same board I soldered CYBLE-212019 module and it got programmed. Anyways I'll give a try by connecting the reset pin also.

0 Likes
Anonymous
Not applicable

Thanks you were correct. One board just flashed without the reset pin connected and the other dint. I connected the reset pin to kitprog, still it dint work. I removed the pull up resistor connected to the reset pin and it then worked.

0 Likes