Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Panometric
Level 5
Level 5
10 likes received 100 sign-ins 100 replies posted

The datasheet says Bluetooth 5.1 Qualified,  but PSoc Creator 4.4 BLE Component v3.66 is only Bluetooth 4.2.  Is this device capable of any of the BLE 5.1 features like connectionless broadcast or extended advertising?

0 Likes
1 Solution
PratikshaV
Moderator
Moderator
Moderator
100 solutions authored 5 likes given 250 sign-ins

Hi @Panometric 

CYBLE-012011-00  module has been qualified for the 5.1 specification, this means that it supports all erratas upto 5.1. When new BLE specification is developed, along with new features, some bugs are fixed in the old spec. Those bug fixes are called erratas. In order to call a device 5.1, minimum requirement is to fix those bugs (erratas).

This module has been qualified for the 5.1 specification, but there is no hardware features update. That means, it will have the 4.2 features only but it supports all erratas upto 5.1.

 

Thanks & Regards

Pratiksha V,

View solution in original post

0 Likes
4 Replies
wayneo
Level 1
Level 1
First reply posted 5 sign-ins Welcome!

Not to Hijack, but I have the exact same question about CYBLE-222014-01. Per datasheet Document Number: 002-11186 Rev. *I;

"The Cypress CYBLE-222014-01 is a fully certified and qualified
module supporting Bluetooth Low Energy 5.1 wireless"

The components/module packaging I received from Mouser states;

"CYBLE-22201-01 EZ_BLE PRoC BT 4.2 M"

0 Likes
PratikshaV
Moderator
Moderator
Moderator
100 solutions authored 5 likes given 250 sign-ins

Hi @Panometric 

CYBLE-012011-00  module has been qualified for the 5.1 specification, this means that it supports all erratas upto 5.1. When new BLE specification is developed, along with new features, some bugs are fixed in the old spec. Those bug fixes are called erratas. In order to call a device 5.1, minimum requirement is to fix those bugs (erratas).

This module has been qualified for the 5.1 specification, but there is no hardware features update. That means, it will have the 4.2 features only but it supports all erratas upto 5.1.

 

Thanks & Regards

Pratiksha V,

0 Likes
Panometric
Level 5
Level 5
10 likes received 100 sign-ins 100 replies posted

Thanks for the clarification.  I would suggest the datasheet be updated to clarify this in the functional section, since the Bluetooth specs can be quite dense. Also, shouldn't the software component datasheet say the same thing? 

Does that mean that there will not be any PSoc4 devices with extended advertising, and that we would need a Psoc6 to get them?

0 Likes

Hi @Panometric 

Sorry for the confusion created and the data is not updated in the documents this will be noted..

Psoc4 will not able to support extended advertising feature so you may need to go devices which supports BLE 5.1 features.

 

Thanks & Regards

Pratiksha V

0 Likes