CY8CKIT-042 always in mass storage

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Level 1
Level 1
First like received


I've two CY8CKIT-042 boards. Both of them are in mass storage mode (CMSIS DAP), with status led slowly fading in a heartbeat-like configuration. I tried to revert from this configuration pressing the SW1 button for more than 5 seconds, but without success.

I also tried to put the firmware kitprog.hex in the mass storage, but I wasn't able to do it (mass storage space appears to be wrong, it gives me 31 MB of free space, while the real max space is 128 kB, and .hex files are all in the order of 600 KB).

What can I do to put the CY8CKIT-042 in programmer/debugger status?

Thank you,


1 Reply
50 likes received 100 solutions authored 250 replies posted

Hi mabe_1335386,

Please ensure that the Jumpers are placed correctly (Jumper near power supply).

Please check whether the reset button is working properly. Since the buttons used are tactile switches, they may become faulty. So use a jumper wire and connect the RESET pin to ground for 5 seconds.

I have tried with a working kit on my side and I also saw the KitProg space as 31.9 MB in mass storage mode. So, I think that is not the root cause of the problem. You can also try this:

1. Remove the kit from the computer.

2. Press the reset button of the kit and insert into the USB port of the computer and release the reset button. This will put the kitprog in Bootloader mode.

3. Then open PSoC programmer and go to the Utilities tab -> Click on Upgrade Firmware. I have attached an image below to show this.


Best Regards,