Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
MiHu_1398501
Level 1
Level 1

We've got a number of bits of deployed hardware that use CY5677's in them, and we've recently started building a new one with a 'red' CY5677 in it, and the software doesn't recognise it:

DongleManager.TryGetCySmartDongleCommunicator

returns err with 'Message = "Not a valid CySmart dongle!"'

Is there a document with the changes needed to support this?

Mike

0 Likes
1 Solution

Unfortunately, no. We don't have any NuGet package available for this. The latest DLLs are available as part of the CySmart software that needs to be added to the code for compilation.

Regards,
Dheeraj

View solution in original post

0 Likes
6 Replies
VenkataD_41
Moderator
Moderator
Moderator
750 replies posted 500 replies posted 250 solutions authored

Hello Mike,

The Red color CY5677 dongle is made using PSoC device where as the older CY5677 dongle is made using PRoC device.

Please refer CySmart 1.3 application for windows source code which supports/recognises both the older and new CY5677 dongles.

You can install the CySmart 1.3 and look at the source code from the link below:

https://www.cypress.com/documentation/software-and-drivers/cysmart-bluetooth-le-test-and-debug-tool

Thanks

Ganesh

0 Likes
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

The reason you are seeing this error is because you are on an older version of the CySmart DLLs. Under References, remove the existing references to the CySmart DLLs highlighted below:

cysmart.PNG

Then right click on References > Add Reference > Browse and add the latest versions of the DLLs available at the path: "C:\Program Files (x86)\Cypress\CySmart\1.3\bin".

After making this change, it should work correctly. Let me know your observations

Regards,

Dheeraj

0 Likes

Is there a nuget package with the latest dlls?

0 Likes

Unfortunately, no. We don't have any NuGet package available for this. The latest DLLs are available as part of the CySmart software that needs to be added to the code for compilation.

Regards,
Dheeraj

0 Likes

I can confirm that moving to the latest cysmart solves our issue.

0 Likes

Glad to hear that the issue is resolved

Regards,

Dheeraj

0 Likes