Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Anonymous
Not applicable

Good afternoon

   

 

   

I'm trying to connect  proc ble with miniprog3 by I2C to tune my proximity cap sensor but connection fails (read operation failed! Check i2c bus connection.). I follow the capsense CSD application note but without success.

0 Likes
10 Replies
lock attach
Attachments are accessible only for community members.
Anonymous
Not applicable

I'm using a CYBLE 022001 - 00, the code of the application note CapSense® Tuning Guide, before program the module i connect sclk and sdat pins of  5 terminal connector of miniprog, i use 2k pull up resistors, the pins i'm using are working. Someone give me a help with this? 

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Welcome in the forum!

   

The MiniProg3 already has got pull-ups for the sclk and sdat lines. You additionally need to connect xres, GND and VCC. Depending on your requirements set the supply voltage for the miniprog correctly. The miniprog may power the chip if you want to,

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Yes, i'm powering the chip with miniprog and i try without pull up resistors but the result is the same.

   

I'm using pins p0.4 for sda and p0.5 for sdl. I program the chip and then i change the connection to this pins.

0 Likes
Anonymous
Not applicable

I analise the i2c output with an oscilloscope the sdl switching frequency is correct if miniprog is connected to i2c, when is not connect the sdl pin doesn't switch. The code i use is the example of application note.

   

void  main()
{   
    //CapSense_1_EnableWidget(CapSense_1_PROXIMITYSENSOR0__PROX);
    CyGlobalIntEnable; 
    CapSense_1_TunerStart();    

    while(1)  
    {        
        CapSense_1_TunerComm();    
    }
}  

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Set the property of your CapSense_1 from "Auto" to "Manual withTuning".

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Continue with same problem i try also change the i2c pins but give me the same error.

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

I2C speed in tuner->Configuration set to 100kbps?

   

No more ideas.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Yes i set to 100kbps, also try with fast and slow slew rate and different frequencies(changed in tuner and i2c block), and i try also with external supply and nothing. I´m without ideas too. Thank you for the help anyway.

0 Likes
Anonymous
Not applicable

I'm open to more ideas...

0 Likes
Bob_Marlowe
Level 10
Level 10
First like given 50 questions asked 10 questions asked

Get the Cypress example running. Remove the LEDs and the associated code. When you have got a development board (ie. Pioneer) try that.

   

 

   

Bob

0 Likes