cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ 4

saga_1136906
New Contributor II

Hi,

I wish start to examine  the booloader with BLE using the example code "BLE_OTA_UpgradableStackExample_Stack01".

The PSOC is 4.4 version. The problem is that the build doesn't create the file .hex but I receive the error message:

"Error in component: Bootloadable. The referenced Bootloader is invalid. Verify the Bootloader dependency is correct in the Bootloadable Component, then build project. Invalid bootloader elf file. Unable to read the elf file (C:\PSoC Creator\BLE_OTA_UpgradableStackExample_Stack01\BLE_OTA_UpgradableStackExample_Stack01.cydsn). The path does not exist".

No build-> no .hex file. May be that there are wrong settings...

Any help?

Thanks in advance!

0 Likes
4 Replies
Alakananda_BG
Moderator
Moderator

Hi,

This error happens when the referenced bootloader component was build with a different version of the components or Creator. Can you try updating the bootloader version.

You can also refer to the below thread 

https://community.infineon.com/t5/PSoC-4/Error-in-Comonent-Bootloadable/m-p/85778

Have you followed the below steps 

Alakananda_BG_0-1637898599984.png

Regards

Alakananda
0 Likes
saga_1136906
New Contributor II

Hi,

thanks for fast reply.

Yes, I did the thread before to post my question. I didn't see any folder created other than "Debug" folder.

First to proceed on the suggested steps I ask if "Update Components" is not the same of "Update firmware"?

Thanks

0 Likes
Alakananda_BG
Moderator
Moderator

Hi,

First to proceed on the suggested steps I ask if "Update Components" is not the same of "Update firmware"?

>>Both are different, you need to update the components to the latest version and try building the project.

Regards

Alakananda
0 Likes
saga_1136906
New Contributor II

I just did that update, but I received that errors...

0 Likes