Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
TeCh_3034126
Level 3
Level 3
First like received First like given

Hi,

I am using CYBLE-214009-EVAL for my development.

In my development, I am using a Android phone (with CySmart APP) to test the device.

It is ok along the development.

In user-trial run, the device cannot connect with iPhone X correctly after several days.

CYBLE_EVT_GAP_AUTH_FAILED, reason: AUTHENTICATION_TIMEOUT” happens.

HOWEVER, the problem device can connect with other Android phones and even iPhone SE/iPhone 6.

Can anyone help me on the issue?

Is there any way to capture more debug information?

Thanks,

Terry

0 Likes
1 Solution
Yugandhar
Moderator
Moderator
Moderator
1000 replies posted 5 likes given First comment on blog

Hello Terry,

You may have to check if your PSoC4 BLE component follows the Advertising and Connection parameters guidelines from Apple to have a stable connection with an Apple product. Here's the link:

https://developer.apple.com/library/archive/qa/qa1931/_index.html

Thanks,

P Yugandhar.

View solution in original post

0 Likes
2 Replies
Yugandhar
Moderator
Moderator
Moderator
1000 replies posted 5 likes given First comment on blog

Hello Terry,

You may have to check if your PSoC4 BLE component follows the Advertising and Connection parameters guidelines from Apple to have a stable connection with an Apple product. Here's the link:

https://developer.apple.com/library/archive/qa/qa1931/_index.html

Thanks,

P Yugandhar.

0 Likes

Will check it. Thanks!

0 Likes