Announcements

Equip yourself to optimize PSoc4 MCUs for Evs at the EV Webinar. Click here to register.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

rrichards
Level 1
Level 1
First question asked Welcome!

I want to add OTA firmware upgrade to my project.  The original project (not developed by me) has no bootloader.  My understanding from reading through Cypress documentation is that I need to create a bootloader project and move the BLE component from the application project to the bootloader project.  When I do this my application won't compile because the BLE component is missing.  Is there a way to have a BLE component in the application project and a different BLE component (specifically for OTA) in the bootloader project?

0 Likes
1 Solution
VenkataD_41
Moderator
Moderator
Moderator
750 replies posted 500 replies posted 250 solutions authored

Hi,

I think you have followed the above mentioned application note already and you are using the Fixed Stack OTA example. Am I Correct?

If yes, we recommend you to use Upgradable Stack OTA Bootloader. Because, with upgradable stack OTA you can upgrade the stack as well as application too.

Answering to your original question, if you are getting the error the reason for getting the compile time errors is because you need to copy the CyBle folder from Booloader to application. Also, you need to add the CyBle folder to the Compiler section.

Please find the attached project for reference. Please update if you have any queries.

Thanks and regards

Ganesh

View solution in original post

0 Likes
2 Replies
VenkataD_41
Moderator
Moderator
Moderator
750 replies posted 500 replies posted 250 solutions authored

Hi,

Your requirement is valid and we have readily available solution for it.

What is the device that you are using? If you are using PSoC 4 BLE, Please go through the PSoC 4 BLE BLE OTA application note for more information. (link given below)

https://www.cypress.com/documentation/application-notes/an97060-psoc-4-ble-and-proc-ble-over-air-ota...

If you are using PSoC 6 BLE device, please go through section 5.3 of the the following appliation note:

https://www.cypress.com/file/385706/download

Hope this helps!

Thanks and regards

Ganesh

0 Likes
VenkataD_41
Moderator
Moderator
Moderator
750 replies posted 500 replies posted 250 solutions authored

Hi,

I think you have followed the above mentioned application note already and you are using the Fixed Stack OTA example. Am I Correct?

If yes, we recommend you to use Upgradable Stack OTA Bootloader. Because, with upgradable stack OTA you can upgrade the stack as well as application too.

Answering to your original question, if you are getting the error the reason for getting the compile time errors is because you need to copy the CyBle folder from Booloader to application. Also, you need to add the CyBle folder to the Compiler section.

Please find the attached project for reference. Please update if you have any queries.

Thanks and regards

Ganesh

0 Likes