Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Nor Flash Forum Discussions

Anonymous
Not applicable

Hi,

   

I am using S70FL01GS as a serial flash interface to nxp k64 series controller. I am not able to get the flash working.

   

I configured spi in mode 0 and also tried with mode 1, but the flash ic does not respond after i send command 0x9f other commands also do not work.

   

I can see the clock and sdo signal from the controller to the IC using oscilloscope, but no response on sdi line. I have made hold signal high, cs low and

   

reset is permanently connected to the ground, cs1 is made high

   

The flash ic does not respond in any situation. kindly help me out with a solution for this.

   

reference designs, sample code will be appreciated.

0 Likes
1 Solution
TakahiroK_16
Employee
Employee
100 replies posted 50 replies posted 25 solutions authored

Hi Sanket,

   

 

   

You must not connect RESET# pin to the ground. If you don't use the RESET#, left it unconnected. If you can attach your oscilloscope capture, I can check other signals' behavior. 

   

 

   

Best Regards,

   

Takahiro

View solution in original post

0 Likes
1 Reply
TakahiroK_16
Employee
Employee
100 replies posted 50 replies posted 25 solutions authored

Hi Sanket,

   

 

   

You must not connect RESET# pin to the ground. If you don't use the RESET#, left it unconnected. If you can attach your oscilloscope capture, I can check other signals' behavior. 

   

 

   

Best Regards,

   

Takahiro

0 Likes