Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Nor Flash Forum Discussions

MoEl_4197781
Level 2
First like given
Level 2

I use S25FL01G  when I use normal 1 line read I got real data stored

but when I use Quad commands if data byte has F (1111) NIPPLE then next clock skip reading next nipple like this

if data stored

0F 10 0F 10 ........

it read

0F 00 F0  ..........

problem is confirmed by logic analyser

0 Likes
1 Solution
MoEl_4197781
Level 2
First like given
Level 2

I got the problem was due to i connected flash to controller board via jumpers

when i do good board with capacitor on power and connect direct to main board it works perfect as manual said

thanks

View solution in original post

0 Likes
4 Replies
AlbertB_56
Moderator
Moderator 50 likes received 250 replies posted 250 sign-ins
Moderator

Hello,

Thank you for contacting Cypress Semiconductor.

Please provide the actual command and latency count you are currently when initiating the QUAD READ operation.

What are the values bit-7 and bit-6 in the Config Register (CR1) [7:6] currently set to?

What is the current operating frequency?

Please provide your findings/results at your earliest convenience.

Best regards,

Albert

Cypress Semiconductor Corp.

An Infineon Technologies Company

0 Likes
AlbertB_56
Moderator
Moderator 50 likes received 250 replies posted 250 sign-ins
Moderator

Hello,

Thank you for contacting Cypress Semiconductor.

Please provide the actual command and latency count you are currently when initiating the QUAD READ operation.

What are the values bit-7 and bit-6 in the Config Register (CR1) [7:6] currently set to?

What is the current operating frequency?

Please provide your findings/results at your earliest convenience.

Best regards,

Albert

Cypress Semiconductor Corp.

An Infineon Technologies Company

0 Likes
MoEl_4197781
Level 2
First like given
Level 2

Thanks for reply

I use current setting

command 6C

QUAD_OUT_FAST_READ_4_BYTE_ADDR_CMD   0x6C

LC =00

DUMMY = 8

freq =1MHZ

I tried all options and failed to get real data without shifting  in both EC and 6C read commands

I tried higher freq 70 MHZ  more corrupted data

0 Likes
MoEl_4197781
Level 2
First like given
Level 2

I got the problem was due to i connected flash to controller board via jumpers

when i do good board with capacitor on power and connect direct to main board it works perfect as manual said

thanks

0 Likes