Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Motor Control ICs Forum Discussions

Level 2
Level 2
10 replies posted 10 sign-ins 5 replies posted


im having trouble with imc101t048q chip to connection with my pc. Chip soldered to designed test board. Here let me tell about what i have done at this time;

I m using generic usb to ttl converter module for programming imc101t using my pc and was first attemed worked well. I have programmed chip when power up the circuit board. After that connection have done and there was no problem for comminication between pc & imc101.  Even i could turn my servo motor with this board.  After a accident i burned my imc101t. Then i ordered new 3 chips from farnell and they arrived today. So my today's job was repair board with new imc101 chips. 

I have soldered and tested board before apply any voltage to it and we see that there is no error or problem at all. Then we apply voltage to it and 3.3v was ok for imc101. At first oneof the gpio pin of imc101t was flicking/blinking randomly before upload program or firmware to it. Using same usb ttl converter module i could succesfully upload firmware and program to it.  During this time, i noticed that some of the other gpio pins of imc101 was on( attached led to them)  by flicking or blinking or even slightly lighting. That was weird because i havent got any script on my program and at first chip which is burned before had no response of gpio pins, althought i used same program.txt file for new chips. After first program was done i was not able to program it again. Everytime i try  it says that " failed to disconnect port" . I have tried to program it with power up my board when usb connected to my computer. I have waited and even fully discharged all capacitors from 3.3V but result didnt changed.

At that moment, i have think that maybe chips is broken too and i decided to replace with new one . Then result was the same as the old one , gpios started to blink / flicking randomly and unexpectedly before upload and firmware or program into it (fully empty chip)


I have tried to explain my problems as much as i  could. Please help me about it . 



13 Replies
50 solutions authored 100 replies posted 10 likes received

Hi @qwertyqwq35 

According to your description, I can only think of these points:

1. For LED blinking randomly, This is abnormal. If you do not use script, the GPIO will not output. Only the status and PGOUT LED can work without script code. Before the first programing (MCE is SBSL mode) the status and PGOUT are also not ouput. Maybe your hardware was damaged when you burned IMC101. Check not only power supply, but also other pins, such as PWM and current sample pin, to ensure that the voltage of these pins  is normal.

2.I suggest you only  supply 3.3V to IMC101. This way,  we can eliminate the influence of high voltage.

3." failed to disconnect port", This means programming failed, and also you cannot connect IMC101 with MCEDesigner. You can use an oscilloscope or logic analyzer to view TX and RX waveforms. Check whether IMC101 responds and whether the waveform is normal, for example baud rate. The baud of programming is 115200.

4. If all of these are normal, The IMC101 should be able to reprogram.





Thank you for suggestion , i will try to solder new board this weekend and i will tell what happens at new board



Hi again 

I have resoldered with new board and new imc101t chip. At first i could program it successfully there was no problem. No led blinking or glitching etc. Only revolution led and status led were lightings. Then after i tried to run my motor but there was nothing happened. Even with fresh im393-x6e chip. That was abnormal and i couldt see what is going on. Then after i thought maybe parameter settings needs to be change so i decided to program it again. When i attach imc101 to my PC , i started to change settings with mcewizard. Then about 5 mins later i realized that pgio12 pin started to glitching and then totally bright up.  But after create a new parameter txt file with wizard , i could upload it to my imc101 chip with no problem at all even gpio12 is lighting with no reason. 

But problem was still there and my motor doesn't move again. Not even a movement happened. 

Because of my system is not protected (tranformerless rectified 230vac) i cannot hook my PC when board energized. And even i have oscilloscope i don't know how to use it tranformerless systems. 

Please help me about it. At first with same circuit board , everything was fine but now it s Dont working what could be happened ? 


Refer MCE Software-RM-UserManual , we can konw that MCE has many protections . But we don't konw what happends on your board as you say.

You can use the isolated USB to TTL tool, or use imotion-link . With these tools, you can operate the board with the power on. Through MCEDesigner you can see what happens when the motor is turned on.

LED of GPIO12 turns on without driver, this is abnormal. You can remove the LED and measure the GPIO12 voltage. Or you can set GPIO12 as output to see if GPIO12 is controlled.




thank you for answer. Today i have managed to see what is going on my circuit let me tell about it.


I have used a isolation transformer to connect my test board to my pc and it worked. Now i can reprogram imc101 on my test board even when main ac power is on. But still doenst move my motor cause of "GATEKILL" error . When i attach to my pc imcdesigner software says that gatekill is accuring for some reason. then i have mesaured GK pin of imc101 and it seems everything is fine 3.14v was comming up from pull up resistor and thanks to 1nF cap , there was no HF noise of my GK voltages as you can see on scope photo down below.  When energy applied to test board, imc101 immediately enters fault mode of GATEKILL. This seems anormal. Because there was no movement at my motor. Even it was not try to turn shaft, it goes to gatekill fault. Then i switched my scope to TRIGGER mode and i see when after every 10secs ,  imc101 tries to reset error but after that time , also imc101 tries to pull GK pin to LOW state for no reason.  And on my old posts, i have told that some of GPIO pins were getting HIGH even there was no script code inside. That problem also solved for no reason and now they are not lighting at all which as we expected.


Can you tell why this could be happens ? Which part of the circuit or software  must be change ?

Thank you

WhatsApp Image 2023-01-17 at 11.31.52.jpeg

WhatsApp Image 2023-01-17 at 11.31.52(1).jpeg




I just made some measurements on my test board. The Iu,Iv,Iw ADC voltage is 0.512v when fault status. And refu,v,w are tied together and voltage is 0.714v. are those voltages ok for working ?



Refu,v,w tied together and with 4.7nf seramic capacitor to gnd


RefUVW is the comparator voltage with IUVW input voltage.

For example, Gatekill source select comparator, and overcurrent trip is 10A.Base on my parameters input. The overcurrent refer voltage is: 10A *20mV/A +300mV = 500mV. This refer voltage is generate by IMC .





For gatekill error, we can check in these point:

1.Gatekill can trigger with two source. If you select Gatekill-Pin only, the gatekill error is depend on GK pin input, only low voltage can trigger. If you select Comparator or both input , you will need refer following points.


2.Leg shunt & singel shunt , this need same with your hardware or will trigger gatekill error.

3.The ADC current feedback gain and input scaling.ADC offset voltage. It also can trigger gatekill error if the wrong parameters input.


4. Current regulator bandwidth is too high, current loop is sharp, or wrong deadtime input cause the current too high when startup the motor.

When energy applied to test board, imc101 immediately enters fault mode of GATEKILL

As your describe, I think your problem should be point 2 and 3.



hi again,


i m still tring to turn my motor shaft. and as you have said  , i have changed all parameters you have ever said to me and motor shaft is rotation hardly with dizzy sound coming from motor. Shaft can complite a full turn hardly with stopping and moving and stopping ...... so on.

I still need some help here and now i m going to share parameter file and current gain part of my test board circuit . Shunt resistors are leg shunt configuration and they are 50milliOhms which connected UVW pins of IM393-x6e through motor windings .

Can you please check it and make sure them correct ?


Level 2
Level 2
10 replies posted 10 sign-ins 5 replies posted

here the option page of mce designer

option page.PNG


I forget to mention,

Still gate kill error appears when energy applied to board, i could only escape from this error by changing  gate kill parameter on me designer by changing it "both" to " comparator". Maybe this one can give a clue to you for solving my question. 


1. Motor start, stop and speed is controlled by extern analog input. If you want to control by MCEDesiger, there should be selected UART.


2. For startup difficulties, Maybe you can increase Low Speed Current Limit.


3. Still gate kill error appears when energy applied to board, i could only escape from this error by changing  gate kill parameter on me designer by changing it "both" to " comparator".

This means that there are still problems. You should check the hardware of GK pin input. Generally, GK input is connected to IPM, you should check if the IPM is fault.