Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
gmp14au
Level 1
Level 1
10 sign-ins First question asked First comment on blog

DC Bus Capacitors 450V, Generated DC Voltage above 600V.png

Hello. I'm trying to configure the controller (EVALM1101TTOBO2) & IPM (EVAL-M1-IM828-A) using "iMOTION Solution Designer". I'm finding it difficult to get the settings right. Please advice. 

The DC Bus Capacitors are of 450V and generated DC Voltage is above 600V dc. Would this not damage the capacitors?

0 Likes
1 Solution
Sahil_K
Moderator
Moderator
Moderator
First like given 100 solutions authored 250 sign-ins

Hi @gmp14au ,

As we can see the Current offset fault has occurred, which may be due to incorrect current feedback settings. Could you please try to modify the following parameters?

  1. Current gain: 54.8mV/A
  2. Offset voltage (voff): 1.07V
  3. ADC gain: 1
  4. DC bus sensing low resistance: 13.3Kohm
  5. Max DC bus voltage: 780V

For additional information on how these values are calculated, please refer to the EVAL-M1-IM828-A user manual. Additionally, to confirm, are you building the project after modifying the parameters and uploading it to the control board?

Note: Please ensure that your motor parameters are correctly configured.

Best Regards,
Sahil Kumar

View solution in original post

0 Likes
1 Reply
Sahil_K
Moderator
Moderator
Moderator
First like given 100 solutions authored 250 sign-ins

Hi @gmp14au ,

As we can see the Current offset fault has occurred, which may be due to incorrect current feedback settings. Could you please try to modify the following parameters?

  1. Current gain: 54.8mV/A
  2. Offset voltage (voff): 1.07V
  3. ADC gain: 1
  4. DC bus sensing low resistance: 13.3Kohm
  5. Max DC bus voltage: 780V

For additional information on how these values are calculated, please refer to the EVAL-M1-IM828-A user manual. Additionally, to confirm, are you building the project after modifying the parameters and uploading it to the control board?

Note: Please ensure that your motor parameters are correctly configured.

Best Regards,
Sahil Kumar

0 Likes