Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Esra
Level 1
Level 1
10 sign-ins First like given 5 sign-ins

Hello, I am using your TLE92104131QXXUMA1 motor driver. Since CPUV is 1, I get SUPE = 1 error and I cannot exit Fail Safe Mode.
Writing in the datasheet;
1. Clear GENSTAT register.
2. Write WDTRIG bit to 1 (GENCTRL1) within the watchdog period.
3. Write WDTRIG bit to 0 within the watchdog period3).
I apply these situations, but I cannot clear the GENSTAT registry. Can you help with this?

0 Likes
1 Solution
Vinay
Moderator
Moderator
Moderator
50 solutions authored 100 replies posted 250 sign-ins

Hello @Esra,

Good Day!

 

Please verify the external capacitors connected across the charge pump.

Ccp should be equal or higher than 470 nF. Ccp1 and Ccp2 should be 220nF.

If Ccp1 and Ccp2 are much bigger or much smaller, the charge pump might charge too slowly. Then CPUV error is reported

 

Please refer Hardware Design Guide Hardware design guide for TLE92108/4

 

Thank you!

 

 

Best Regards,
Vinay

View solution in original post

0 Likes
7 Replies
RupakC
Moderator
Moderator
Moderator
100 solutions authored 250 sign-ins 25 likes received

Hello @Esra 

The following is the description of the GENSTAT register:

RupakC_0-1662362552180.png

The GENSTAT register contains the CPUV bit. It sets to 1 when the charge pump under-voltage is detected. The CPUV is also set in case of temperature shutdown and Vs under-voltage.

Can you let us know what is the exact values of the GENSTAT register bits… which of the bits of GENSTAT register are not getting cleared ?

Regards

 

RupakC
0 Likes
Vinay
Moderator
Moderator
Moderator
50 solutions authored 100 replies posted 250 sign-ins

Hi @Esra,

Good Day!

 

I have not heard from you since my last response on September 13. I assume that this is because the issue is resolved.

If, however, the issue is not resolved, please do let me know and I shall work with you to ensure that the issue is resolved.

You can always reopen this case or create a new case for any other issue. We will be happy to help you in resolving your issues.

 

Thank you!

 

Best Regards,
Vinay
0 Likes
lock attach
Attachments are accessible only for community members.
Esra
Level 1
Level 1
10 sign-ins First like given 5 sign-ins

Hello @RupakC 

When I read the GENSTAT registry without cleaning, I read 0x0001. When I clear and read the GENSTAT registry, I read 0x0001 again. In this case, it only gives the CPUV 1 value and causes an error.

After clearing, I read the Global Status Byte 0x58. So the NPOR bit is 1. The datasheet says GENSTAT is doing a cleanup when NPOR is 1. I'm cleaning but CPUV is 1 again. How can I solve this problem?

Thank you for the answer.

 

0 Likes
Vinay
Moderator
Moderator
Moderator
50 solutions authored 100 replies posted 250 sign-ins

Hello @Esra,

Good Day!

 

A charge pump under voltage event is reported after a power-on reset, when the charge time of the capacitor connected to VCP exceeds tCPUV time.

Desired charge pump capacitor connected between VS and CP  should be greater than 470 nF. If we connect very high capacitor across VS and CP, it will require more time to charge and exceeds tCPUV time and report under voltage.

 

Thank you!

 

Best Regards,
Vinay
Esra
Level 1
Level 1
10 sign-ins First like given 5 sign-ins

Hello @Vinay 

I am outing of Fail safe mode but still charge pump error is continue. Actually FS must be "1" when CPUV is "1".Fail safe mode must continue when CPUV=1.I am using 470nF cap for charge pump and this cap is charging tCPUV time.What should i do? 

0 Likes
Vinay
Moderator
Moderator
Moderator
50 solutions authored 100 replies posted 250 sign-ins

Hello @Esra,

Good Day!

 

Please verify the external capacitors connected across the charge pump.

Ccp should be equal or higher than 470 nF. Ccp1 and Ccp2 should be 220nF.

If Ccp1 and Ccp2 are much bigger or much smaller, the charge pump might charge too slowly. Then CPUV error is reported

 

Please refer Hardware Design Guide Hardware design guide for TLE92108/4

 

Thank you!

 

 

Best Regards,
Vinay
0 Likes
Vinay
Moderator
Moderator
Moderator
50 solutions authored 100 replies posted 250 sign-ins

Hi @Esra,

Good Day!

 

I just wanted to check if you received my previous response. Is there anything we can do to assist you better with your request?

 

Thank you!

 

Best Regards,
Vinay
0 Likes