Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
PauloM
Level 2
Level 2
First solution authored First like given 10 sign-ins

Hi,

 

I have a problem with running a induction motor in reverse.

The motor runs well in one direction, but when i try to run in the other direction the current doesn't increase much, and the motor doesn't start.

 

To run the motor in reverse, i tried two ways:

1 - Duty-cycle control, and directional pin.

2 -  Uart control by MCE Designer

In both ways i could only run the motor the same direction. When trying the motor in the other direction, the comands were given, but the motor didn't move. I could see the set speed being increasing as it should in a negative value.

 

I don't know if it is a step that i miss,  or some of the parameters of the motor are wrong.

I assume the parameters are correctly defined because the motor is working well in one direction.

If someone can help me with this, i highly apreciate it.

 

Thank you 

0 Likes
1 Solution
PauloM
Level 2
Level 2
First solution authored First like given 10 sign-ins

Hi @Krupashankar ,

I figured out what was the problem, now it runs in both directions.

The problem is that the example script for induction motor in Induction motor control by iMOTION™ (infineon.com) only changes the voltage to positive speed values, i altered the script to do the same to negative speed values and now it works.

 

Thanks for all the help,

Paulo

 

View solution in original post

0 Likes
3 Replies
Krupashankar
Moderator
Moderator
Moderator
500 replies posted 50 likes received 25 likes received

Hi @PauloM,

Can you please let us know if you are trying to change the direction during run time? If No,

Can you try changing( R-Y-B to Y-R-B) the phase of the motor connected to the inverter?

 

Thanks,

Krupashankar

0 Likes

Hi @Krupashankar,

I let the motor come to a stop before trying to run it in the other direction.

 

I changed 2 of the phases connected to the inverter, as you said, and noticed that the motor only runs in positive direction, that is, when the velocity in the controler is set to positive. This ocurred before and after changing the phases.

What could it be?

 

Best Regards,

Paulo

 

0 Likes
PauloM
Level 2
Level 2
First solution authored First like given 10 sign-ins

Hi @Krupashankar ,

I figured out what was the problem, now it runs in both directions.

The problem is that the example script for induction motor in Induction motor control by iMOTION™ (infineon.com) only changes the voltage to positive speed values, i altered the script to do the same to negative speed values and now it works.

 

Thanks for all the help,

Paulo

 

0 Likes