Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
JasonLEE
Level 5
Level 5
100 replies posted 250 sign-ins First like received

Hello

I changed winding for motor stator.

Because It was to problem of overtemperature.

So It changed the spec on Ld , Lq , Back EMF (ke).

Originally this motor is working well but after winding changed it have problem is flux.

After changed , It have another problem of flux estimator.

Motor is working well but 300rpm situation is have error code on flux out of control

It does not rpm ramp up

I don't know this cause.

Can you help me this problem?

I attached this video and parameters.

Please check it.

0 Likes
1 Solution
Viswa
Moderator
Moderator
Moderator
10 likes received 50 solutions authored 100 replies posted
Hi @JasonLEE 
 
Improper configuration of the following lead to Flux out of control Fault:
  • Incorrect number of pole pairs
  • Improper configuration of Flux estimator time constant( usually 4 to 5 times of L/R)
  • Improper configuration of PLL KP and PLL ki
Please configure all the above parameters and let us know the results.
 
Best Regards

View solution in original post

0 Likes
1 Reply
Viswa
Moderator
Moderator
Moderator
10 likes received 50 solutions authored 100 replies posted
Hi @JasonLEE 
 
Improper configuration of the following lead to Flux out of control Fault:
  • Incorrect number of pole pairs
  • Improper configuration of Flux estimator time constant( usually 4 to 5 times of L/R)
  • Improper configuration of PLL KP and PLL ki
Please configure all the above parameters and let us know the results.
 
Best Regards
0 Likes