Announcements

Curious on how you can apply Motor Control ICs to Smart Home Appliances? Register for the ASEAN Smart Home Appliance Webinar here to find out how.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Motor Control ICs Forum Discussions

sudip_k
Level 1
First like given 5 replies posted 5 questions asked
Level 1

MCE Designer becomes unresponsive and no longer able to turn off the Motor every time I tired to run PFC first and then run Motor.
But there is no problem if I turn on only one(either pfc or Motor) and run.

The  tools that I use for this application are: EVAL-M3-302F for controller and  EVAL-M3-CM615PN for power board. I have the latest version of MCE designer installed which is v2.3.1 and the MCE wizard that I have is v2.3.1. The firmware package that I use for board is IMC302A-F064 MCE Software Package v1.3.3 

0 Likes
1 Solution
Krupashankar
Moderator
Moderator 250 replies posted 100 solutions authored 5 likes given
Moderator

Hi @sudip_k,

Can you please share the Trace settings in MCE Designer?

Please try reducing the sample rate.

Please follow below steps to reduce sample rate for the trace:

  • Right Click PFC_VacRaw & PFC_IpfcRAW 
  • Select >> Define Trace
  • Reduce the sample rate and try 
  • Krupashankar_0-1660888829315.png

     

Please try above setting and let us know if this helps to solve the problem.

 

Thanks,

Krupashankar

View solution in original post

0 Likes
7 Replies
Krupashankar
Moderator
Moderator 250 replies posted 100 solutions authored 5 likes given
Moderator

Hi @sudip_k,

Please try installing other versions of MCE Wizard from Tool Brief MCEWizard v2.3 and please let us know if this solves the issue.

can you please let us know the following:

  • Windows Version
  • If any active trace is enabled in MCE Designer and its setting

 

Thanks,

Krupashankar

0 Likes
sudip_k
Level 1
First like given 5 replies posted 5 questions asked
Level 1

Hi, thank you for the reply. I have tried installing the older version too but the problem still exists. Should I try installing all the older versions one by one and check?

I have windows 10 and there is no active trace enabled. 

 

0 Likes
Krupashankar
Moderator
Moderator 250 replies posted 100 solutions authored 5 likes given
Moderator

Hi @sudip_k,

Apologies for the delayed response. 

Can you please try using a different PC and see if the problem still persists?

 

Thanks,

Krupashankar

0 Likes
sudip_k
Level 1
First like given 5 replies posted 5 questions asked
Level 1

Hi, I have tried using two different PCs  and observed the same problem. My intention is to evaluate PFC part of the design.  I cant view PFC related waveforms(trace) and run both Motor and PFC at the same time. Please check the attached screenshots. 

0 Likes
Krupashankar
Moderator
Moderator 250 replies posted 100 solutions authored 5 likes given
Moderator

Hi @sudip_k,

Can you please share the Trace settings in MCE Designer?

Please try reducing the sample rate.

Please follow below steps to reduce sample rate for the trace:

  • Right Click PFC_VacRaw & PFC_IpfcRAW 
  • Select >> Define Trace
  • Reduce the sample rate and try 
  • Krupashankar_0-1660888829315.png

     

Please try above setting and let us know if this helps to solve the problem.

 

Thanks,

Krupashankar

0 Likes
Viswa
Moderator
Moderator First like received 100 sign-ins 25 replies posted
Moderator

Hi @sudip_k 

Please let us know if you are able to work with MCE designer

Best Regards,

0 Likes
sudip_k
Level 1
First like given 5 replies posted 5 questions asked
Level 1

Hi, 

Now I am able to work with MCE designer after reducing the MCE cpu load by slightly decreasing the Motor PWM frequency. And also by the changing sample rate.

0 Likes