Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Motor Control ICs Forum Discussions

sudip_k
Level 2
Level 2
10 questions asked 10 sign-ins First like given

Hi,

 

I am currently using EVAL-M3-102T and EVAL-M3-CM615PN to run a BLDC motor. I have no problem running the motor at above 200 RPM. However when I try to run at low RPM between 30 to 100, the torque is very weak. The motor can't run with heavy load at these low speeds.

How do I solve this?

I am currently using only back emf(sensorless). My application requires the motor to run between 20 to 300RPM with a nominal load weight of 15KG. 

 

Thanks

 

 

0 Likes
1 Solution
Viswa
Moderator
Moderator
Moderator
50 replies posted 250 sign-ins 10 solutions authored

Hi @sudip_k 

The system operates in open-loop mode at low RPM, 

can you please share the motor datasheet and please try to operate the motor in current loop.

Please follow the attached link as reference to operate high inertia loads

AN2020-12 Driving high inertia loads with iMOTION™2.0

Best Regards,

View solution in original post

0 Likes
1 Reply
Viswa
Moderator
Moderator
Moderator
50 replies posted 250 sign-ins 10 solutions authored

Hi @sudip_k 

The system operates in open-loop mode at low RPM, 

can you please share the motor datasheet and please try to operate the motor in current loop.

Please follow the attached link as reference to operate high inertia loads

AN2020-12 Driving high inertia loads with iMOTION™2.0

Best Regards,

0 Likes