Flashing issues in BPA software while using IMD_700A_FOC_3SH

Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
GG_Prasanth21
Level 1
Level 1
First reply posted First like given First question asked
I facing the initial level of flashing and debugging problems with BPA software and EVAL_IMD700A_FOC_3SH board. 
 
  1. I selected the FOC Sensor less method in BPA software. On the application side, I used the BLDC (drone motor).
  2. I put the measured values of the motor in the configurator of the0_project_and_firmware_selection.jpg1_flasing_default_code.jpg2_default_firware_flashes_successfully.jpg3_write_with_customized_initial_values.jpg4_facing_flashing_errors.jpg5_project_didn't_work.jpg BPA software. 
  3. I have faced the issue while flashing. Sometimes it will flash successfully and also live values are shown in the test bench of BPA software. 
  4. The problems are faced with "incorrect firmware".
  5. Sometimes the default firmware was flashed successfully, but the initial parameters do not flash.  
  6. All of the issues are attached through the pictures.
Kindly check and give support to me. 
0 Likes
1 Solution
lock attach
Attachments are accessible only for community members.
Vinay
Moderator
Moderator
Moderator
50 solutions authored 100 replies posted 250 sign-ins

Hi @GG_Prasanth21,

Good Day!

Thanks for posting your question in Infineon Community.

 

Please verify the type of parameter you are changing in BPA motor control GUI.

The type of Parameters are Power Cycle parameter (P), Advanced parameter (A), Standby Parameter (S), and OTP Parameter (O)

 

If P is mentioned in front of the parameter, It's a Power cycle parameter.

 

Power cycle parameters: Programming this parameter will have an effect only after hardware power cycle.

Power cycle reset in the sense, resetting BPA motor control GUI, resetting SPI Communication and resetting DC supply.

 

Please verify the Parameter Info tab in BPA Motor control GUI for other parameter types.

 

Thank you!

 

Best Regards,
Vinay

View solution in original post

0 Likes
2 Replies
lock attach
Attachments are accessible only for community members.
Vinay
Moderator
Moderator
Moderator
50 solutions authored 100 replies posted 250 sign-ins

Hi @GG_Prasanth21,

Good Day!

Thanks for posting your question in Infineon Community.

 

Please verify the type of parameter you are changing in BPA motor control GUI.

The type of Parameters are Power Cycle parameter (P), Advanced parameter (A), Standby Parameter (S), and OTP Parameter (O)

 

If P is mentioned in front of the parameter, It's a Power cycle parameter.

 

Power cycle parameters: Programming this parameter will have an effect only after hardware power cycle.

Power cycle reset in the sense, resetting BPA motor control GUI, resetting SPI Communication and resetting DC supply.

 

Please verify the Parameter Info tab in BPA Motor control GUI for other parameter types.

 

Thank you!

 

Best Regards,
Vinay
0 Likes
Vinay
Moderator
Moderator
Moderator
50 solutions authored 100 replies posted 250 sign-ins

Hi @GG_Prasanth21,

Good Day!

 

Did Hardware power cycle reset solve your problem?

 

Thank you!

Best Regards,
Vinay
0 Likes