Announcements

From sunburn to sun earn – we’ve got the power! Watch our #poweringgreen videos now.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
Kyle
Level 1
Level 1
First question asked Welcome!

While performing testing on the Eval-M1-CM610N3 board, I accidentally applied -15V to the Vcc pins of the J2 Interface Connector. Since then, the auxiliary power supply circuit will not generate Vcc from the DC Bus. I've replaced C105 and U6. Does anyone have any suggestions for any approaches to solving this problem? 

Thank you.

0 Likes
1 Solution
psb
Moderator
Moderator
Moderator
250 sign-ins 25 solutions authored 100 replies posted

Hello @Kyle ,

    Is the problem persisting after replacing the above 2 components ?
    Can you please let me know how you're powering up the board ? 

  I would suggest to replace the damaged components and also disconnect any short circuits at the outputs in the auxiliary power supply circuit, and then start the board by applying input ac voltage or more preferably power up only the auxiliary power supply by giving only the DCP supply externally by gradually increasing it and monitoring the VCC. 

Thanks,
Sai

Best Regards,
Sai

View solution in original post

0 Likes
2 Replies
psb
Moderator
Moderator
Moderator
250 sign-ins 25 solutions authored 100 replies posted

Hello @Kyle ,

    Is the problem persisting after replacing the above 2 components ?
    Can you please let me know how you're powering up the board ? 

  I would suggest to replace the damaged components and also disconnect any short circuits at the outputs in the auxiliary power supply circuit, and then start the board by applying input ac voltage or more preferably power up only the auxiliary power supply by giving only the DCP supply externally by gradually increasing it and monitoring the VCC. 

Thanks,
Sai

Best Regards,
Sai
0 Likes
psb
Moderator
Moderator
Moderator
250 sign-ins 25 solutions authored 100 replies posted

Hello @Kyle ,

  Any update on the issue ?

Thanks,
Sai

Best Regards,
Sai
0 Likes