Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Panometric
Level 5
Level 5
10 likes received 100 sign-ins 100 replies posted

mtb-pdl-cat1\release-v2.4.1 has v1.7.0 of arm_math.h But I have another library brought in with an mtb that needs V1.9.0 

I followed the pack extract method from https://community.infineon.com/t5/ModusToolbox/Install-CMSIS-DSP-for-CY8CPROTO-062-4343W-on-ModusToo...

Perhaps the problem is larger, the library needs DSP from ARM.CMSIS.5.7.0.pack 

How can one control the order files are found using MTB make?

When is a way to integrate ARM.CMSIS.5.7.0 DSP that  resolves the version conflict with mtb-pdl-cat1 using MTB 2.4?

 

 

 

0 Likes
1 Solution
LeoMathews
Moderator
Moderator
Moderator
First question asked 500 replies posted 100 solutions authored

Hi @Panometric ,

Can you please clarify the statement "But I have another library brought in with an mtb that needs V1.9.0"? Can you please try providing the path of the include folder in DSP( ARM.CMSIS.5.7.0.pack) in the INCLUDES variable in the Makefile?

Thanks and Regards,
Leo

View solution in original post

0 Likes
2 Replies
LeoMathews
Moderator
Moderator
Moderator
First question asked 500 replies posted 100 solutions authored

Hi @Panometric ,

Can you please clarify the statement "But I have another library brought in with an mtb that needs V1.9.0"? Can you please try providing the path of the include folder in DSP( ARM.CMSIS.5.7.0.pack) in the INCLUDES variable in the Makefile?

Thanks and Regards,
Leo

0 Likes
LeoMathews
Moderator
Moderator
Moderator
First question asked 500 replies posted 100 solutions authored

Hi @Panometric ,

Thread was locked due to inactivity for long time, you can continue the discussion on the topic by opening a new thread with reference to the locked one. The continuous discussion in an inactive thread may mostly be unattended by community users.

Thanks and Regards,
Leo

0 Likes