Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
KaKo_4074056
Level 4
Level 4
Distributor - Marubun (Japan)
First like given First solution authored 25 replies posted

Hi,

I have a problem with New Application by MTB. Please give me some advice.

I installed MTB v3.0 in the following directory. I used 123456 as my username here, but it's actually another 6 digit number.
C:\Users\123456\ModusToolbox

MTB has two errors to launch New Application.

1.

error: pathspec 'release-v4.2.0' did not match any file(s) known to git
INFO:directory 'C:/ProgramData/Infineon_Technologies_AG/Infineon-Toolbox' does not exist

The directory does not exist on my pc.

2. 

ERROR:there was an error retreiving the asset 'https://github.com/Infineon/device-db' commit 'release-v4.2.0' - error: pathspec 'release-v4.2.0' did not match any file(s) known to git

I saw the thread below with a similar error, but my username does not contain spaces.
https://community.infineon.com/t5/ModusToolbox-General/Project-Creator-error-retreiving-the-asset-de...

KaKo_4074056_0-1685696442889.png

Best regards

0 Likes
1 Solution
KaKo_4074056
Level 4
Level 4
Distributor - Marubun (Japan)
First like given First solution authored 25 replies posted

Hi Nanda,

Thanks for your reply. My issue was already settled. It was caused by not having permission to run Cygwin on the newly distributed PC.

Best regards

View solution in original post

6 Replies
MuhammadNanda_K
Moderator
Moderator
Moderator
50 solutions authored 250 sign-ins 250 replies posted

Hello @KaKo_4074056 ,

Based on the installation Guide:
https://www.infineon.com/dgdl/Infineon-ModusToolbox_3_0_Installation_Guide-GettingStarted-v01_00-EN....
in first part of section 6, You must:
"If possible, create a new user account and ..."
Therefore, this will not works if only create new folder manually under "C:\Users\"

May I know if you create new user account or only create new folder ?

Other option is you can use custom folder (the new manual created folder is a custom folder/path) by following section 6.1 to 6.5.

Please kindly update your status / information,
so we may know if we can try more workaround(s). 

Thank you and regards,
Muhammad Nanda

0 Likes
KaKo_4074056
Level 4
Level 4
Distributor - Marubun (Japan)
First like given First solution authored 25 replies posted

Hi nandax,

Thank you for your reply.

I thought that the creation of this thread I originally posted failed and an empty thread in the link below was created. I apologize for not only creating an empty thread, but also creating duplicate thread. I'm followed by Charles_Lai at the link in the thread below.

https://community.infineon.com/t5/ModusToolbox-General/Modus-Toolbox-New-Application-error/m-p/44566...

Best regards

0 Likes

Ok @KaKo_4074056 ,

So you will continue discussion with this topic on another thread instead ?
If yes, this thread should be closed.

Thank you and regards,
Muhammad Nanda

0 Likes
KaKo_4074056
Level 4
Level 4
Distributor - Marubun (Japan)
First like given First solution authored 25 replies posted

Hi Nanda,

Thanks for your reply. My issue was already settled. It was caused by not having permission to run Cygwin on the newly distributed PC.

Best regards

Okay @KaKo_4074056 ,

Glad to hear your issue was solved. I will close this thread.
If you have another query(is), please do not hesitate to create new thread(s). 🙂

Thank you and regards,
Muhammad Nanda

0 Likes
LeoMathews
Moderator
Moderator
Moderator
First question asked 500 replies posted 100 solutions authored

Hi @KaKo_4074056 ,

Thread was locked due to inactivity for long time, you can continue the discussion on the topic by opening a new thread with reference to the locked one. The continuous discussion in an inactive thread may mostly be unattended by community users.

Thanks and Regards,
Leo

0 Likes