Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Chva_1477726
Level 4
Level 4
25 sign-ins 10 sign-ins First solution authored

Hi.

I have created a test project in Modus 3.1 with about 50 lines of code in each of the cores.

Building it takes close to 3 minutes. My PC has a 20 core CPU running at >4.5GHz with 64GB RAM and the latest 2GB  M2 SSD. 

I have set the .ini file to allow Java to use up to 8GB memory, starting from 512MB, I have enabled unlimited parallel build jobs in the build behavior and nothing seems to make any difference.

I am not a fan of Modus Toolbox, but having no other choice, I have to use it and this issue is not helping to change my point of view.

Any help will be appreciated.

1 Solution

Hi

I  am ok now, thank you!

Regards

Chris

View solution in original post

0 Likes
11 Replies
ChiP_16
Employee
Employee
5 questions asked 5 likes given 5 solutions authored

Hi,

In the release note of modustoolbox.

For certain applications (typically a factor of size),Eclipse may present a "Discover Compilation Database Settings" dialog displays, which can block the UI for several seconds/minutes. This is seen to happen often after a build of the project.

Right-click the project and select Properties > C/C++ General >Preprocessor Include Paths > Providers, and deselect the Compilation Database Parser check box. Note that this will cause IntelliSense to be disabled for that application.

Chva_1477726
Level 4
Level 4
25 sign-ins 10 sign-ins First solution authored

Hi. Compilation Database Parser check box is deselected.

0 Likes
ChristopherF_51
Employee
Employee
100 sign-ins 25 solutions authored 10 likes given

Hi,

We are sorry to hear that you have not had a good experience with ModusToolbox. We suspect you may be encountering an issue with Eclipse as described below.

Problem

When building a multi-core application using the Quick Panel Build Application link in the Eclipse IDE for ModusToolbox 3.1, the application and core projects may build multiple times, thus causing the build to take an excessively long time.

This issue occurs in an Eclipse multi-core application because the application (Mulitcore_Empty_App) and core projects (proj_cm0p, proj_cm7_0) have references to each other, and these references cause Eclipse to rebuild the entire application several times.

Workaround

To work around this problem, you can disable the Project References.

Right-click on the application and select Properties > Project References. Then, deselect all the entries on the dialog.

ChristopherF_51_0-1688156941840.png

 

Repeat this process for every core project (proj_cm4, proj_cm0p, etc.).

ChristopherF_51_1-1688156941845.png

 

After a clean, you should see a significant speed up for the total build time.

We believe this issue is only encountered using the Eclipse IDE, and not using Visual Studio Code or the command line (modus-shell).

Note: We made this change to address a problem on Windows 11 for IntelliSense in the Eclipse CDT. So, if you're using Windows 11, you may see the IntelliSense issue when disabling the Project References. If this is not desirable, you can use the modus-shell terminal to build the application by running "make build" instead of using the Eclipse IDE Quick Panel. Build Application.For example:

$ make build -j8

Another option could be to use Visual Studio Code to develop your application. For more details about that, refer to the Visual Studio for ModusToolbox™ user guide.

Chva_1477726
Level 4
Level 4
25 sign-ins 10 sign-ins First solution authored

Hi.

Thank you for your response. I am running on Windows 11.

All the references were already deselected, so I am no closer to a resolution.

I hope you can start to understand my absolute frustration with Modus Toolbox. It is the IDE recommended by Infineon for development of the PSoC6 and probably the only IDE that will be supported in future.

First it was the absolute insane way to start a project by selecting a board and then hack the resulting creation into something resembling your requirements. That has thankfully improved somewhat.

I switched to Cypress MCU's way back because of the ease of using PSoC Creator. If I was not so heavily invested in the Cypress/Infineon MCU's, I would have switched to another vendor already because of Modus Toolbox.

Listening to Alan Hawse sing the praises of Modus toolbox, I sometimes wondered if I installed the wrong tool!

Infineon should look around at the IDE's of their competitors and come to the party to make it attractive for people to adopt their MCU's, not scare away longtime customers that adopted and promoted their products.

Switching now to move over to Visual Studio presents another level of development abstraction by adding yet another vendors tools into the mix and I just wonder where to go for support in that case.

I will try the command line suggestion, but if that does not work I will most like loose the last few hairs I have left.

0 Likes

HI

The make build -j8 made no difference, so I downloaded the Visual Studio Code software, added the recommended extensions, exported and imported the application from Modus Toolbox and built it.

No improvement whatsoever.

Are there any IDE's out there that supports the PSoC6 family that does not have the word MODUS somewhere in the vocabulary or rely on a Modus Toolbox extension to work?

I am really running out of options.

Regards

Chris

0 Likes
MYKZ
Employee
Employee
25 sign-ins 5 solutions authored 10 replies posted

Hi Chris.

I am sorry you are not having good experience with our Tools.

This kind of a performance is unusual.

Can we have a short call, preferably with screen sharing so that we can look at the problem together?

Additionally, could you please archive and attach the application that you have created? (no need to include the libs, mtb_shared, build, and GeneratedSource directories (see guide 7.1.1))

 

Thank you very much!

   Mykhailo

0 Likes
Chva_1477726
Level 4
Level 4
25 sign-ins 10 sign-ins First solution authored

Hi Mikhailo

I would appreciate a shared screen session. What I have done since, was to completely re-install Windows and all my applications to see if my PC was the cause in some way. I finished that process this morning, but it looks like the performance is still the same.

Please contact me by email and I can share my files with you and set a session up. 

What tool do you prefer to use, Teams, AnyDesk ...?

0 Likes

Further to then perfoirmance issue, I now also get the following error :

cc1.exe: error: too many filenames given; type 'cc1.exe --help' for usage

I have stripped everything out except the main.c file and it still persists.

0 Likes
Chva_1477726
Level 4
Level 4
25 sign-ins 10 sign-ins First solution authored

Hi Mykhailo

After the reload of Windows and experiencing the issues, I also deleted my complete workspace and started fresh.

The completely empty application build in 17s now. I will begin to reconstruct the application.

I kept a backup of the previous workspace and I would appreciate it if you can still log in remotely to see what happened in order for me to prevent the same from happening again.

Regards

Chris

0 Likes

Hello @Chva_1477726 ,

Please let us know if you are having any queries. 

Thanks,

P Yugandhar. 

0 Likes

Hi

I  am ok now, thank you!

Regards

Chris

0 Likes