Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

ToPe_1312931
Level 4
Level 4
10 replies posted 10 questions asked 5 replies posted

I just downloaded and installed Modus Toolbox. I tried to create an empty project and get the following error. Lot's of '('s in my path.

/bin/bash: -c: line 0: syntax error near unexpected token `('

/bin/bash: -c: line 0: `env PATH="/usr/bin:/bin:/usr/bin:/cygdrive/c/development/ModusToolbox/tools_2.0/jre-1.0/bin/server:/cygdrive/c/development/ModusToolbox/tools_2.0/jre-1.0/bin:/cygdrive/c/development/ModusToolbox/tools_2.0/jre-1.0/lib/amd64:/cygdrive/c/Program Files (x86)/Common Files/Oracle/Java/javapath:/cygdrive/c/Windows:/cygdrive/c/Windows/system32:/cygdrive/c/Windows/system32/Wbem:/cygdrive/c/Windows/system32/WindowsPowerShell/v1.0:/cygdrive/c/Program Files/Common Files/Microsoft Shared/Windows Live:/cygdrive/c/Program Files (x86)/Common Files/Microsoft Shared/Windows Live:/cygdrive/c/Program Files (x86)/NVIDIA Corporation/PhysX/Common:/cygdrive/c/ProgramData/Oracle/Java/javapath:/cygdrive/c/development/ti/ccsv6/utils/cygwin:/cygdrive/c/development/yagarto-tools-20070303/bin:/cygdrive/c/Program Files/IDM Computer Solutions/UltraEdit:/cygdrive/c/Program Files (x86)/Windows Kits/8.1/Windows Performance Toolkit:/cygdrive/c/development/Vagrant/bin:/cygdrive/c/Program Files (x86)/Windows Live/Shared:/cygdrive/c/development/Qt/5.7/mingw53_32/bin:/cygdrive/c/cygwin/bin:/cygdrive/c/smartmontools/bin:/cygdrive/c/QNX650/host/win32/x86/usr/bin:/cygdrive/c/QNX641/QNX Software Systems/bin:/cygdrive/c/development/jdk1.8.0_45/bin:/cygdrive/c/development/MAVProxy:/cygdrive/c/python3:/cygdrive/c/development/gcc-none-8/bin:/cygdrive/c/development/codesourcery/bin:/cygdrive/c/QNX641/host/win32/x86/usr/bin2:/cygdrive/c/Program Files (x86)/GNU Tools ARM Embedded/4.8 2014q3/bin:/cygdrive/c/Program Files (x86)/Nmap:/cygdrive/c/smartmontools/bin:/cygdrive/c/Users/tpeterson/AppData/Local/particle/bin:{"properties":{"Status":"Success"},"event":"Install Done","context":{"os":{"name":"Windows","version":"7 (64 bit)"}},"anonymousId":"pluto//tpeterson S-1-5-21-3271878515-4168016174-4170296575-1001/r/n"}:/cygdrive/c/development/ModusToolbox/ide_2.0/eclipse" bash --norc --noprofile C:/development/ModusToolbox/tools_2.0/make/getlibs.bash C:/development/ModusToolbox/workspace/Empty_PSoC6_App C:/Users/tpeterson /cygdrive/c/development/ModusToolbox/workspace/Empty_PSoC6_App/libs 5 "-e C:/development/ModusToolbox/workspace/Empty_PSoC6_App/build"'

make: *** Error 1

"make getlibs" failed.

Failed to create "Empty_PSoC6_App" application.

1 Solution
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Please remove the following values from the environment PATH variable:

{"properties":{"Status":"Success"},"event":"Install Done","context":{"os":{"name":"Windows","version":"7 (64 bit)"}},"anonymousId":"pluto//tpeterson S-1-5-21-3271878515-4168016174-4170296575-1001/r/n"}

After removing the values, click Apply. Close and open ModusToolbox and try again.

Let me know if it works.

Regards,

Dheeraj

View solution in original post

2 Replies
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

Please remove the following values from the environment PATH variable:

{"properties":{"Status":"Success"},"event":"Install Done","context":{"os":{"name":"Windows","version":"7 (64 bit)"}},"anonymousId":"pluto//tpeterson S-1-5-21-3271878515-4168016174-4170296575-1001/r/n"}

After removing the values, click Apply. Close and open ModusToolbox and try again.

Let me know if it works.

Regards,

Dheeraj

Yes. That worked. I don't know where that garbage came from.