cancel
Showing results for 
Search instead for 
Did you mean: 

ModusToolbox™ General

Dobre
New Contributor II

Good day!

I use CYBT-353027 and work in ModusToolbox studio. Yesterday I tried SPP example with my PC. I don't know why and is it the issue or not but until yesterday I can download hex file in the ModusToolbox studio but now it gives me errors:

------------------------------------------------------------------------------------------------------------------------------------------------------------------

Detecting serial port ...
Serial port not detected...
Download failed

If the serial port was not detected, make sure no other program such as ClientControl has the port open.

If you have issues downloading to the kit, follow the steps below:

Press and hold the 'Recover' button on the kit.
Press and hold the 'Reset' button on the kit.
Release the 'Reset' button.
After one second, release the 'Recover' button.
make[1]: *** [../mtb_shared/wiced_btsdk/dev-kit/baselib/20706A2/release-v3.1.0/COMPONENT_20706A2/make/recipe/program.mk:102: qprogram] Error 1
make: *** [../mtb_shared/core-make/release-v1.8.0/make/core/main.mk:426: secondstage_build] Error 2

------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

I still can download hex with ChipLoad.exe and WICED MODULE Programmer but is not convenient. I have even reinstalled ModusToolbox and COM drivers and try several USB port - it is useless.

I get read https://community.infineon.com/t5/PSoC-6/SPP-programming-error-CYBT-353027/m-p/289907but it is not helpful

What can be done to solve the problem? Thanks!

 

Best regards,

Dobre

0 Likes
1 Solution
DheerajPK_41
Moderator
Moderator

Hi,

I see this problem. I think it is due to mismatch of baudrate and some issue with the download system. 

Could you please "Programming with Recovery Procedure" steps which is explanined in the https://community.infineon.com/t5/Knowledge-Base-Articles/Programming-an-EZ-BT-WICED-Module-KBA22342...

In short. 

Use a jumper wire to connect the HCI UART_CTS to ground and do the recovery - -reset as suggested and then disconnect the jumper wire. Now the device will be on the recovery mode. At this stage, use the chipload tool to download the application (.hex) as mentioned in the above blog.

Thanks,

-Dheeraj.P.K

View solution in original post

0 Likes
2 Replies
DheerajPK_41
Moderator
Moderator

Hi,

I see this problem. I think it is due to mismatch of baudrate and some issue with the download system. 

Could you please "Programming with Recovery Procedure" steps which is explanined in the https://community.infineon.com/t5/Knowledge-Base-Articles/Programming-an-EZ-BT-WICED-Module-KBA22342...

In short. 

Use a jumper wire to connect the HCI UART_CTS to ground and do the recovery - -reset as suggested and then disconnect the jumper wire. Now the device will be on the recovery mode. At this stage, use the chipload tool to download the application (.hex) as mentioned in the above blog.

Thanks,

-Dheeraj.P.K

View solution in original post

0 Likes
Dobre
New Contributor II

Thanks, Dheeraj.P.K!

P.S.

WICED_MOD_Programmer.exe can be also used instead of ChipLoad.exe. It is important to remove CTS-GND jumper after recovery procedure.

Best regards,

Dobre

0 Likes