Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

ModusToolbox™ General Forum Discussions

NXTY_Tatebayasi
Level 3
Level 3
10 questions asked 10 likes given 10 replies posted

Dear Community,

Please give me some advice on my problem.

Project Creator 2.0 (BSP) has a problem with the firewall, the Source Template is blank. As the picture show bellow Fig1-2. 

I understand Modus tool Box version 3.0 has an option to run in offline mode, and I need install the Offline development package(KBA236233 ).

On the other hand, I also understand that in version 2.x there is a way around this problem in the proxy settings.

So,I have two quesutions.

1. Will version 3.0 implement a way to work around firewall issues with proxy settings?

2. Is there any solution other than offline mode to solve this problem?

[Error massages]

ERROR:there was an error retreiving the asset 'https://github.com/Infineon/device-db' commit 'release-v4.0.2' - the git repo 'C:/Users/103739/.modustoolbox/offline/git/https___github.com_Infineon_device-db/device-db' does not contain the commit 'release-v4.0.2'

ERROR:Global asset download of device-db loading completed with error.

ERROR:The asyncStepComplete failed for LoadFlag DEVICE_DB.

NXTY_Tatebayasi_2-1667202948711.png

Fig.1  View of  Project Creator 2.0.0.3807  (Offline mode)

NXTY_Tatebayasi_3-1667203218588.png

Fig.2 View of  Project Creator 2.0.0.3807  (Direct mode)

 

Regards,

Chihiro Tatebayashi

 

 

 

 

0 Likes
1 Solution
Charles_Lai
Moderator
Moderator
Moderator
250 replies posted 100 solutions authored 100 replies posted

Hi,

You're using an out-of-date offline package that isn't suitable for MTB 3.0. So it can't provide the 'device-db' content for you.

Did you have to use MTB in offline mode only?

Best regards

View solution in original post

0 Likes
11 Replies
ChristopherF_51
Employee
Employee
25 likes received 50 sign-ins 10 solutions authored

Hello,

The Project Creator and Library Manager tools have a Settings menu with an option to set the Proxy. That should resolve the issue.

Hello,

Thank you for your help.

I tried Proxy server settings and switched manual mode.

But, the probrem still occurs, I can now only launch BPS in offline mode.

We checked the proxy and there was no problem with the hostname and port id.

NXTY_Tatebayasi_0-1667866540255.png

I consider that entering BPS offline mode requires the PC to be in airplane mode or offline.
Is this correct?

Please let me know if there is anything I should try other than offline mode.

Regards,

0 Likes

Hello,

If you can open this URL in a web browser, then you should be able to set the proxy setting to Direct: https://github.com/Infineon/mtb-super-manifest/blob/v2.X/mtb-super-manifest-fv2.xml

If not, you need to set the proxy value as appropriate. Another option is to use HTTP_PROXY and HTTPS_PROXY environment variables. If those aren't working, then here's an article about connectivity problems: https://docs.github.com/en/get-started/using-github/troubleshooting-connectivity-problems

If you want to use offline content, please read section 6.3 in the user guide: https://www.infineon.com/dgdl/Infineon-ModusToolbox_3.0_Tools_Package_User_Guide-GettingStarted-v13_...

If you are using ModusToolbox version 2.4, please make sure you have installed the patch https://softwaretools.infineon.com/tools/com.ifx.tb.tool.modustoolboxpatch24

In Project Creator or Library Manager, when you switch to Offline mode, you should see a message like this:

Getting manifests from offline contents...

#################################################################################################### 100%

Found offline super-manifest: file:///C:/Users/XYZ/.modustoolbox/offline/manifests-v2.X/mtb-super-manifest-fv2.xml

Processing super-manifest file:///C:/Users/XYZ/.modustoolbox/offline/manifests-v2.X/mtb-super-manifest-fv2.xml...

Hope this helps!

Hello, ChristopherF_51 san

Thank you for your reply and resolving this issue.

I was able to open this link.

However, from BSP2.0, it was not opened when going through.

https://github.com/Infineon/mtb-super-manifest/blob/v2.X/mtb-super-manifest-fv2.xml

 

I wasn't using ModusToolbox 2.4, but installed it additionally to the patch it.

And,  I was able to install the older version of the BSP(Project Creator 1.41.0.3849).

Since I can't use two different BSP versions( BSP 2.0 and 1.4 ) while booting ModusToolbox 3.0, I adopted the old version of BSP to use it online.

I referred how to select a different BSP version, that "1.4.4 Specifying alternate tools version" in the ModusToolbox tools  package  user guide( AN29893 ).

Valiable name : CY_TOOLS_PATHS

Valiable value : C:/Users/xxx/ModusToolbox\tools_2.4

This issue was solved by your advice.

 

Regards,

Chihiro Tatebayashi

Charles_Lai
Moderator
Moderator
Moderator
250 replies posted 100 solutions authored 100 replies posted

Hi,

Try following the link below:
https://community.infineon.com/t5/Code-Examples/ModusToolbox-URL-Modifier/td-p/366015

It should set you free.

Best regards

Hi,

Thank you for your help and posting the link.

Despite running the command, the problem did not go away.

I understand that I should add the script below,

url "https://ghproxy.com/https://github.com"]
insteadOf = https://github.com  

Which file can I refer to to confirm that the path has changed?

 

Regards,

0 Likes

In Modus-shell, run the command below to add it to ModusToolbox system:

git config --system url."https://ghproxy.com/https://github.com".insteadOf https://github.com

You can use "git config -l" to confirm it.

Hi, Charles_Lai san

Thank you for your reply.
I was able to confirm the following.

$ git config -l
url.https://ghproxy.com/https://github.com.insteadof=https://github.com

However, I was unable to reach the GitHub repository in Direct mode.

Therefore, I think that it is necessary to solve this problem other than the method you taught me.

I will install the MTB version to 2.4 and apply a patch to see if the problem of connecting to GitHub can be resolved.

Regards,

Chihiro Tatebayashi

0 Likes
Charles_Lai
Moderator
Moderator
Moderator
250 replies posted 100 solutions authored 100 replies posted

Hi,

You're using an out-of-date offline package that isn't suitable for MTB 3.0. So it can't provide the 'device-db' content for you.

Did you have to use MTB in offline mode only?

Best regards

0 Likes

Hi, Charles_Lai san

It was as you pointed out.

My confirmation was lacking, MTB3.0 could not create projects with older BSP versions.

So I modified the environment variables to launch BSP 2.0.

Due to my company's firewall, I can only create new projects in offline mode.

However, I have confirmed that BSP2.0 can access the repository without problems in Direct mode on an external network(eg. my home) .

 

Best regards,

Chihiro Tatebayashi

0 Likes