Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

ModusToolbox™ General Forum Discussions

zdlwzh2006
Level 2
25 sign-ins First solution authored 10 sign-ins
Level 2

以前的项目一直用V2.2开发,以后的项目准备用V2.4开发。

现在同一台PC里安装了这2个版本的MODUS,但是用V2.2的MODUS打开以前的项目build时发现MODUS用的是

V2.4的GCC编译,请问怎么解决两个版本共存的问题?

Previous projects have been developed with V2.2, and future projects are ready to be developed with V2.4.

Now these two versions of modus are installed on the same PC, but when opening the previous project build with Modus V2.2,it is found that Modus is compiled with V2.4 GCC. How can we solve the problem of the coexistence of the two versions?

 

 

0 Likes
1 Solution
MykhailoZ_21
Employee
First question asked 5 replies posted First solution authored
Employee

you need to set the CY_TOOLS_PATHS system variable. See also 3.2 Installing with previous versions in the https://www.infineon.com/dgdl/Infineon-ModusToolbox-Installation-Guide_3-GettingStarted-v01_00-EN.pd...

I have simple bat file to switch between the two when on Windows, with something like:

@ECHO OFF
ECHO Starting Eclipse for ModusToolbox 2.4
set CY_TOOLS_PATHS=C:/Users/zelyanovskym/ModusToolbox/tools_2.4
ECHO Tools Version: %CY_TOOLS_PATHS%
start C:\Users\zelyanovskym\ModusToolbox\ide_2.4\eclipse\ModusToolbox.exe

PAUSE

View solution in original post

0 Likes
3 Replies
Qi_Colin
Moderator
Moderator 25 solutions authored 100 replies posted 100 sign-ins
Moderator

Hi @zdlwzh2006 :

两个不同版本的IDE可能会产生冲突问题,不建议在同一台电脑上共存。

Modus版本是可向下兼容的,请问用Version 2.4维护2.2版本的project有遇到什么问题么?

Best Regard,

Colin

0 Likes
MykhailoZ_21
Employee
First question asked 5 replies posted First solution authored
Employee

you need to set the CY_TOOLS_PATHS system variable. See also 3.2 Installing with previous versions in the https://www.infineon.com/dgdl/Infineon-ModusToolbox-Installation-Guide_3-GettingStarted-v01_00-EN.pd...

I have simple bat file to switch between the two when on Windows, with something like:

@ECHO OFF
ECHO Starting Eclipse for ModusToolbox 2.4
set CY_TOOLS_PATHS=C:/Users/zelyanovskym/ModusToolbox/tools_2.4
ECHO Tools Version: %CY_TOOLS_PATHS%
start C:\Users\zelyanovskym\ModusToolbox\ide_2.4\eclipse\ModusToolbox.exe

PAUSE

0 Likes
zdlwzh2006
Level 2
25 sign-ins First solution authored 10 sign-ins
Level 2

Thank you very much. I have solved the problem.

0 Likes