Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

ModusToolbox™ General Forum Discussions

Len_CONSULTRON
Level 9
Level 9
500 solutions authored 1000 replies posted 750 replies posted

AnyCloud_BLE_Multi_Beacon not working with CY8CPROTO-062-4343W as downloaded using "New Application" in "Quick Panel".

Although, CY8CPROTO-062-4343W is not listed as one of the supported BSPs in the README.md file, the project is allowed under MTB 2.4 as a 'valid' MTB BSP.

Note:  Using MTB 2.4.

Note:  It compiles and programs the BSP without error.

Here is the Terminal output of the Debug port info.

 

***********AnyCloud Example***********
****Multi Beacon Application Start****
**************************************

Bluetooth Stack Initialization Successful
Bluetooth Enabled
Local Bluetooth Address: 43:43:A1:12:1F:AC
Multiple ADV started.
Use a scanner to scan for ADV packets.
Multi ADV Set Data Event Status: FAILED
Multi ADV Set Param Event Status: FAILED
Multi ADV Start Event Status: FAILED
Multi ADV Set Data Event Status: FAILED
Multi ADV Set Param Event Status: FAILED
Multi ADV Start Event Status: FAILED

I suspect that the code example has not been updated with changes needed for MTB 2.4.

Help would be appreciated.

Len
"Engineering is an Art. The Art of Compromise."
0 Likes
1 Solution
BragadeeshV
Moderator
Moderator
Moderator
First question asked 1000 replies posted 750 replies posted

Hi @Len_CONSULTRON ,

It looks like the support for multi advertisements has been removed for 4343W controller. That is why this CE is failing for this BSP. I can confirm the same from the HCI logs as well as from the multi_adv_resp_status in BTM_MULTI_ADVERT_RESP_EVENT event.

BragadeeshV_0-1646994871867.png

 

Regards,
Bragadeesh

View solution in original post

0 Likes
3 Replies
BragadeeshV
Moderator
Moderator
Moderator
First question asked 1000 replies posted 750 replies posted

Hi @Len_CONSULTRON ,

It looks like the support for multi advertisements has been removed for 4343W controller. That is why this CE is failing for this BSP. I can confirm the same from the HCI logs as well as from the multi_adv_resp_status in BTM_MULTI_ADVERT_RESP_EVENT event.

BragadeeshV_0-1646994871867.png

 

Regards,
Bragadeesh
0 Likes

Bragadeesh,

Thanks for looking into it.

If multi-advertisements are removed, they're removed.

Suggestion:  You may want to remove this CY8CPROTO-062-4343W for this Application so that "New Application" will not configure it.

Len
"Engineering is an Art. The Art of Compromise."
0 Likes
BragadeeshV
Moderator
Moderator
Moderator
First question asked 1000 replies posted 750 replies posted

Hi @Len_CONSULTRON ,

I agree, we have let our internal team know to update the manifests correctly.

Regards,
Bragadeesh
0 Likes