Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

ModusToolbox™ General Forum Discussions

YiCh_4772066
Level 1
Level 1

I installed the ModusToolbox and offline package follow the ModusToolbox Installation Guide and have set the system variable to specify the path to Tools.

But  create an example Hellow World have the follow error

Log file(s) for this session are stored at: D:\Users\HAYMAN~1\AppData\Local\Temp\Logs6614219753211729983

Opening project creator from D:/Tool/ModusToolbox/tools_2.1/project-creator/project-creator

Importing Hello_World (1/1) ...

Error creating Eclipse launch configurations: Makefile:163: *** Unable to find any of the available CY_TOOLS_PATHS -- D:\Tool\ModusToolbox\tools_2.1 .  Stop.

Done.

Unable to find configurator information: Makefile:163: *** Unable to find any of the available CY_TOOLS_PATHS -- D:\Tool\ModusToolbox\tools_2.1 .  Stop.

Phlease help, TKS!

0 Likes
1 Solution
Charles_Lai
Moderator
Moderator
Moderator
250 replies posted 100 solutions authored 100 replies posted

Hi,

Two more suggestions:

  • a) Try to completely uninstall and then reinstall ModusToolbox to make sure your ModusToolbox and all its components are presenting.
  • b) Their is also a macro / variable named "CY_TOOLS_PATHS" in your project's makefile, which is located at the root of your project. You can check or alter it, to help you analyze the issue.

Best regards

View solution in original post

0 Likes
3 Replies
Kenshow
Level 8
Level 8
50 solutions authored 25 solutions authored 10 solutions authored

Hi,

The message is that CY_TOOLS_PATHS is not available, so if you think about it normally, you doubt this path or path setting.

It seems that there are similar posts in the past, so it is recommended to search by CDC.

For example, how about the following?

 

Re: ModusToolbox on Linux HelloWorld example

Regards,

Kenshow

0 Likes
Charles_Lai
Moderator
Moderator
Moderator
250 replies posted 100 solutions authored 100 replies posted

Hi,

Two more suggestions:

  • a) Try to completely uninstall and then reinstall ModusToolbox to make sure your ModusToolbox and all its components are presenting.
  • b) Their is also a macro / variable named "CY_TOOLS_PATHS" in your project's makefile, which is located at the root of your project. You can check or alter it, to help you analyze the issue.

Best regards

0 Likes

I modify the  "CY_TOOLS_PATHS"  in makefile , Then the problem solved. Thank you!

0 Likes