Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

ModusToolbox™ General Forum Discussions

Akshay_C
Level 1
10 sign-ins 5 questions asked 5 sign-ins
Level 1

 

Hello Team,

 

I am trying to program CYBT-343026-01 module using external FTDI (FT232RL USB to TTL) using MODUS toolbox. I have done following connection. 

 

FTDI       CYBT module

+3.3V        + 3.3V

Gnd       -Gnd

Txd         -Rxd

Rxd        -Txd

RTS         -CTS

CTS         -RTS

 

On MODUS toolbox console shows ERROR: unable to find CMSIS-DAP Device.

how to solve this error kindly let me know.

 

Thanks & Regards,

Akshay

 

0 Likes
1 Solution
BragadeeshV
Moderator
Moderator First question asked 1000 replies posted 750 replies posted
Moderator

Hi @Akshay_C ,

Firstly, we recommend you to upgrade to the latest MTB version, ie MTB 2.3 for your application. 

https://www.cypress.com/products/modustoolbox

Since you are using a USB-UART bridge, we will be using the HCI UART for programming. Therefore, you need to use the Program option and not the Attach_Kitprog3_Miniprog4 which is used for openOCD attaching to running target without initial programming. 

BragadeeshV_1-1623759233718.png

Please let us know if this resolves the issue.

Regards,
Bragadeesh

View solution in original post

0 Likes
3 Replies
BragadeeshV
Moderator
Moderator First question asked 1000 replies posted 750 replies posted
Moderator

Hi @Akshay_C ,

Can you ensure that you have followed the connections between the USB-UART device and the CYBT module are provided in the CYBT-343026 eval board?

https://community.cypress.com/t5/ModusToolbox-General/CYBT-343026-Module-Programming/td-p/279896

Can you share the screenshot error log you see from the Modustoolbox?

Please let us know which version of Modustoolbox you are using.

Regards,
Bragadeesh
0 Likes
Akshay_C
Level 1
10 sign-ins 5 questions asked 5 sign-ins
Level 1

Hi @BragadeeshV 

Yes I have done same connection as provided in CYBT-343026 eval board schematic.

Kindly check below connections.

 
 
 

FTDI CONNECTION.png

 

 

I am  using ModusToolbox IDE v2.0 & Getting Below Error log.

 

Akshay_IOTLYNX_1-1623757171685.png

 

Regards,

Akshay

0 Likes
BragadeeshV
Moderator
Moderator First question asked 1000 replies posted 750 replies posted
Moderator

Hi @Akshay_C ,

Firstly, we recommend you to upgrade to the latest MTB version, ie MTB 2.3 for your application. 

https://www.cypress.com/products/modustoolbox

Since you are using a USB-UART bridge, we will be using the HCI UART for programming. Therefore, you need to use the Program option and not the Attach_Kitprog3_Miniprog4 which is used for openOCD attaching to running target without initial programming. 

BragadeeshV_1-1623759233718.png

Please let us know if this resolves the issue.

Regards,
Bragadeesh
0 Likes