Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

ModusToolbox™ General Forum Discussions

benmike000
Level 1
Level 1
First like given 5 sign-ins First reply posted

The ModusToolbox version I installed is 2.4. There is a problem blow occurred after I launched ModusToolsbox. 

MTB_issue.JPG

Nothing will happen if I create a project by clicking File-->New-->ModusToolsBox. I have tried to reinstall version 2.4 again and even install version 3.0, but the issue is still there. 

How to resolve this issue? Thanks

 

 

0 Likes
1 Solution

Looking at previous cases of this issue occurring, it looks like it is tied to Coverity 2018.12. Can you confirm what version of Coverity you have installed?
As a workaround, you can remove the ..\Coverity\Coverity Static Analysis\bin path from your Path variable (Write this down somewhere so you can restore it later though) or uninstall Coverity.

We are still investigating this bug and looking for a long term solution.

View solution in original post

6 Replies
LeoMathews
Moderator
Moderator
Moderator
100 sign-ins 25 solutions authored 100 replies posted

Hi @benmike000 

Can you please confirm whether have followed the default installation for ModusToolbox2.4/ModusToolbox3.0 as specified in the ModusToolbox installation guide?

Can you also make sure you have set the system environment variables mentioned in the provided documentation? Are you using windows operating system?

Thanks and Regards,
Leo

0 Likes

Thanks for your feedback. My operation system is win10, and I installed the modusToolsbox to the default location. It seems that I do not need to set the system environment variables if I install ModusToolbox software in the default location.

Regards,

BM

0 Likes
zhanben
Employee
Employee
First solution authored First like received First reply posted

Hi,
Some users report similar issues occuring when Coverity is included in the "Path" environment variable.
Do you have Coverity installed? Can you provide the install path, and show us what you have your "Path" environment variable set to?

Hi, 

You are right. The Coverity is installed on my PC, it's install path is "C:\Program Files\Coverity\Coverity Static Analysis", see my "Path" environment variable below:

system_environment.JPG

I look forward to your further support.  Thanks

 

BR,

BM

0 Likes

Looking at previous cases of this issue occurring, it looks like it is tied to Coverity 2018.12. Can you confirm what version of Coverity you have installed?
As a workaround, you can remove the ..\Coverity\Coverity Static Analysis\bin path from your Path variable (Write this down somewhere so you can restore it later though) or uninstall Coverity.

We are still investigating this bug and looking for a long term solution.

I have tried this workaround,  this problem is no longer happening. 

My Coverity version is 2021.12. Wish your team can fix this bug in the near future. Thanks!

0 Likes