Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Mbed SDK Forum Discussions

RaPe_4640831
Level 1
Level 1

Mbed Studio seem to require DAPLink mode to connect to above board. My board was in CMSIS-DAP BULK mode and the "Mode" switch button was toggling between BULK and HID mode. When I tried to use the fw-loader to switch to DAPLINK mode it's failing though the KitProg3 version is 1.11. Please let me know how to get this working. Appreciate your help.

Here is the info:

./fw-loader.exe --device-list

Cypress Firmware Updater, Version: 2.2.11.491

(C) Copyright 2018-2020 by Cypress Semiconductor

All Rights Reserved

Info: Start API initialization

Info: Connected - KitProg3 CMSIS-DAP BULK-100B03F302098400

Info: Hardware initialization complete (502 ms)

Connected supported devices:

        1: KitProg3 CMSIS-DAP BULK-100B03F302098400     FW Version 1.11.159

./fw-loader.exe --mode kp3-daplink

Cypress Firmware Updater, Version: 2.2.11.491

(C) Copyright 2018-2020 by Cypress Semiconductor

All Rights Reserved

Info: Start API initialization

Info: Connected - KitProg3 CMSIS-DAP BULK-100B03F302098400

Info: Hardware initialization complete (499 ms)

Info: Disconnected - KitProg3 CMSIS-DAP BULK-100B03F302098400

Info: Connected - KitProg3 CMSIS-DAP BULK-100B03F302098400

Error: Wait for device DAPLink connect is timed out

Mode switch on 'KitProg3 CMSIS-DAP BULK-100B03F302098400' device failed.

0 Likes
1 Solution

The problem was resolved once I downloaded fw-loader.exe version 2.2.11.491 that contains KitProg3 1.14. After updating my board using the command "fw-loader.exe --update-kp3" the board could get into DAPLink mode. Hope this helps anyone having the same issue.

View solution in original post

0 Likes
5 Replies
DheerajK_81
Moderator
Moderator
Moderator
First comment on KBA First comment on blog 5 questions asked

We fixed some defects with transitioning to DAPLink modes in the latest version of fw-loader. Please download the version which fixes this here.

Then run the following commands in sequence:

(1) ./fw-loader.exe --update-kp3

(2) ./fw-loader.exe --mode kp3-daplink

Let me know if it works!

Regards,

Dheeraj

Hi Dheeraj,

Thanks a lot for your reply. I will try your suggestion and let you know if this solves the problem or not.

Regards,

Ram

0 Likes
RaPe_4640831
Level 1
Level 1

Hi Dheeraj,

I tried your suggestion and it did NOT work. The mode switch to DAPLink is not working. Is this board "ARM-mbed enabled"? Please let me know.

Regards,

Ram

0 Likes

No, this board is not Mbed enabled. You can find the list of supported boards here: Development boards | Mbed

But it does have DAPLink support. When you say it is not working, what is happening when you press the mode switch? Was the fw-loader upgrade successful? Pressing the mode switch should cycle you through the three modes. The DAPLink mode is the one where the Kitprog3 status LED ramps at 2Mhz. Do you see this?

Please connect your board to Cypress Programmer and check the console information.

Regards,

Dheeraj

0 Likes

The problem was resolved once I downloaded fw-loader.exe version 2.2.11.491 that contains KitProg3 1.14. After updating my board using the command "fw-loader.exe --update-kp3" the board could get into DAPLink mode. Hope this helps anyone having the same issue.

0 Likes