Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

MOTIX™ MCU Forum Discussions

jotoffel
Level 1
Level 1
5 sign-ins First reply posted First question asked

Hello,
I have updated my new uIO stick according to the manual by executing "UpdateBSL.cmd".
Now the stick is not recognised as HDI device any more.


Unfortunately I did not make a screenshot of the console after the update, the only thing I remember was, that after programming it said to press "any key" to continue and then the console closed.


On the device it self there is only the 5V and 3.3V LED green – no other LEDS are on.


I guess fw update might faild and the device is no dead. Is there a change to program the uIO stick with j-link or Lauterbach?
BR

DeviceManager.PNG

0 Likes
1 Solution
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi All,

The uIO stick was getting corrupt due to uploading the new firmware. It will be fixed soon.

Please send the uIO sticks to the following address to fix the corrupted uIO stick:

Address:
Attn: Mr Bhushan Joshi
RMA: UIO Reflash

Hitex GmbH
Greschbachstr. 12
76229 Karlsruhe / Germany

Hitex will fix these uIO sticks and send them back directly.

Please let us know if you have any issues.

Thank you

Best Regards

Raj Chaudhari

View solution in original post

0 Likes
10 Replies
jcfjcf45200
Level 1
Level 1
5 replies posted 5 sign-ins First reply posted

Hello Jotoffel, 

I've the same problem after uptaded my µIO-stick with the script. I think the problem comes from the firmware  supplied in the package, the size is only 17 KB. I updated an other µIO-Stick with Config Wizzar, v2.2.2, the size of this firmware is 222 KB.

We tried to flash directly the µcontroller of the µIO-Stick with a J-flash prob, but it is not recognized by J-Flash.

Actually, no solution find.

0 Likes
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @jotoffel,

Could you please confirm if you have programmed the latest version of the BSL firmware? (Please find it in the attachment) 

If the programming is successful it will display like the following:

Raj_JC_0-1671185930706.png

 

Please let us know if you followed above mentioned points.

Thank you

Best Regards

Raj Chaudhari

0 Likes
jcfjcf45200
Level 1
Level 1
5 replies posted 5 sign-ins First reply posted

I think it is not the last version, the release date is 2018, I updated my µIO-stick with the version supplied by Config Wizard, V2.2.2.

0 Likes
jotoffel
Level 1
Level 1
5 sign-ins First reply posted First question asked

Hello,

@jcfjcf45200 

Thank you for your answer. Yes, it seems like the same issue. Unfortunatally I only have one stick available, so I cannot try with Config Wizzar.

@Raj_JC 

Thank you for your answer. I run the script which came with the BSL-TOOLS package. There it says FW ‘bsl_1.1.867.fw’. I guess I had the same output as you showing in your console output.

 

0 Likes
jcfjcf45200
Level 1
Level 1
5 replies posted 5 sign-ins First reply posted

I had a meet with Infineon this morning, normally  the procedure described in the µIO-stick manual must work, the guy tell me he applied this procedure in his office, it works fine, but we applied in the procedure with my PC and my µIO-stick, and we had the same problem, now it is bricked. He must see with his colleague why it is happened and find a solution to unbrick the µIO-stick. If a solution is found, I will post the solution of course.

0 Likes
Stab
Level 1
Level 1
First reply posted Welcome!

Hi, I have the same issue. I also used the firmware from the BSL Tool package. 

Looking forward to a solution.

0 Likes
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi,

We have forwarded this issue to our internal team, who are evaluating this query.
We will provide a response as soon as we get an update from our internal team.
Thank you for your patience.

Thanks and Regards,
Raj Chaudhari

0 Likes

Hello Raj,
Thanks for the update. Do you might know a way to avoid this problem with a new uIO stick? I have ordered two new ones and do not want to lock them as well.
BR

 

BR

0 Likes
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi All,

The uIO stick was getting corrupt due to uploading the new firmware. It will be fixed soon.

Please send the uIO sticks to the following address to fix the corrupted uIO stick:

Address:
Attn: Mr Bhushan Joshi
RMA: UIO Reflash

Hitex GmbH
Greschbachstr. 12
76229 Karlsruhe / Germany

Hitex will fix these uIO sticks and send them back directly.

Please let us know if you have any issues.

Thank you

Best Regards

Raj Chaudhari

0 Likes

Ok, thanks a lot. I will send my µIo-stick to Hitex.

0 Likes