Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

MOTIX™ MCU Forum Discussions

Myhoney
Level 1
Level 1
First reply posted First question asked Welcome!

Hello,

I am new to this software, and the config wizard report these error messages after start. I have no idea why would this happen,  can someone please take a look of the error message? 

Myhoney_0-1672824005936.png

Myhoney_1-1672824049678.png

Another problem I have is that the pin overview page in my Config Wizard is all black, but according to the demo I should be able to see the pin layout here, what should I do to fix this problem?

Myhoney_2-1672824245802.png

Please help me with these questions! Thanks a lot.

 

 

 

 

 

 

 

 

 

0 Likes
1 Solution
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @Myhoney,

 

It seems that you have accessed the .icwp file directly using the config wizard.

Please try to access the ConfigWizard's .icwp file using Keil IDE. Please follow the steps given below to access the .icwp file without errors:

 1) Integrate the Config Wizard by following the steps given at the section 'Toolchain installation for Keil µVision5 Step 2: Infineon Developer Center and Config Wizard (2)' in the Evaluation Board and Evaluation Kit
Getting Started for MOTIX™ TLE986x/7x. (Page no. 7)

2) After integration refer to the section 'Getting Started with Keil µVision5 Step 6: Use the Config Wizard v2 (1)' in the Evaluation Board and Evaluation Kit Getting Started for MOTIX™ TLE986x/7x. (Page no.26)

 

Please let us know if you need further support.

Thank you

Best Regards

Raj Chaudhari

View solution in original post

0 Likes
4 Replies
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @Myhoney,

Please, let us know the following details to get the faster resolution.

1) Could you please let us know the software version for the Config Wizard for MOTIX MCU?

2) Which .icwp file is loaded in the config wizard or which application you are referring to?

Thank you

Best Regards

Raj Chaudhari

0 Likes
Myhoney
Level 1
Level 1
First reply posted First question asked Welcome!

Hello, Raj,

1). The software version I am using is 2.7.2.202206291845

2). The .icwp files I used are from "CCU7_PWM_EXAMPLE_TLE989X_BDRV_MEAS" and "HV_MON_PWM", and  both of them have the same problems.

Many thanks!

 

0 Likes
0 Likes
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @Myhoney,

 

It seems that you have accessed the .icwp file directly using the config wizard.

Please try to access the ConfigWizard's .icwp file using Keil IDE. Please follow the steps given below to access the .icwp file without errors:

 1) Integrate the Config Wizard by following the steps given at the section 'Toolchain installation for Keil µVision5 Step 2: Infineon Developer Center and Config Wizard (2)' in the Evaluation Board and Evaluation Kit
Getting Started for MOTIX™ TLE986x/7x. (Page no. 7)

2) After integration refer to the section 'Getting Started with Keil µVision5 Step 6: Use the Config Wizard v2 (1)' in the Evaluation Board and Evaluation Kit Getting Started for MOTIX™ TLE986x/7x. (Page no.26)

 

Please let us know if you need further support.

Thank you

Best Regards

Raj Chaudhari

0 Likes