TLE9879 can't send LIN message

Announcements

Webinar: Integrated solutions for smaller, simpler low-voltage motor control design.
Join the webinar to experience!

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
User15455
Level 2
Level 2
10 sign-ins 5 sign-ins 10 replies posted

Hello,

I used the TLE9879 demo code(driving a BLDC motor with sensorless FPC controlled over LIN) to develop our project.  Sometimes LIN didn't work properly. TLE9879 could received messages from the master, but it couldn't send messages back to the master. Could you please help to check what's the root cause? Thanks

0 Likes
1 Solution
Kevin_Wu
Moderator
Moderator
Moderator
50 solutions authored 100 sign-ins 50 replies posted

Hi there,

 According to spec. 

• LROM(LIN receiver only mode) - LNM (LIN normal mode) transition is executed when:
– CTRL_STS.MODE is configured to LIN Normal Mode and
– Feedback signals of Mode and Slope Mode are ok (see Chapter 20.3.2) and
– VS undervoltage flag (SYS_SUPPLY_IRQ_STS.VS_UV_STS) is not set and
– LIN transceiver CTRL_STS.OT_STS and CTRL_STS.OC_STS are not set and LIN transceiver
– no CTRL_STS.TXD_TMOUT is set

After voltage goes normal, the  VS Undervoltage flag will goes to 0, as it is ready only register and controlled by HW.   so if all configuration is right, the LIN should goes to normal mode.

Thanks, Kevin

View solution in original post

0 Likes
3 Replies
Kevin_Wu
Moderator
Moderator
Moderator
50 solutions authored 100 sign-ins 50 replies posted

Hi there,

   for LIN communication, the master and slave are different in HW and SW.

For HW:  master node need 1K resister to bus

Kevin_Wu_0-1659333500802.png

and slave is  30K

Kevin_Wu_1-1659333611946.png

For SW, make sure it is right.

 

thanks, Kevin

 

0 Likes

Hi Kevin,

It seems 9879 goes into receive-only mode at low voltage. How to recover from receive-only mode without power cycle? Thanks 

0 Likes
Kevin_Wu
Moderator
Moderator
Moderator
50 solutions authored 100 sign-ins 50 replies posted

Hi there,

 According to spec. 

• LROM(LIN receiver only mode) - LNM (LIN normal mode) transition is executed when:
– CTRL_STS.MODE is configured to LIN Normal Mode and
– Feedback signals of Mode and Slope Mode are ok (see Chapter 20.3.2) and
– VS undervoltage flag (SYS_SUPPLY_IRQ_STS.VS_UV_STS) is not set and
– LIN transceiver CTRL_STS.OT_STS and CTRL_STS.OC_STS are not set and LIN transceiver
– no CTRL_STS.TXD_TMOUT is set

After voltage goes normal, the  VS Undervoltage flag will goes to 0, as it is ready only register and controlled by HW.   so if all configuration is right, the LIN should goes to normal mode.

Thanks, Kevin

0 Likes