Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

MOTIX™ MCU Forum Discussions

jcfjcf45200
Level 1
Level 1
5 replies posted 5 sign-ins First reply posted

Hello, 

I'm trying to flash a TLE987x EvalBoard with a TLE9872QX with a new µIO-Stick but it is not possible to connect  it to the target.  I connected the µIO-stick to the eval board  powered with 12V external supply .

I

1670245309650.jpg

I'm using BSL_Tool application from the BSL-TOOLS_2022-02-26 package with Windows 10.

When I launch BSL-Tools, the "Connect" button is orange, it means the µIO-stick is recognized by windows

jcfjcf45200_0-1670246153413.png

In the peripheral manager in windows, no error is detected.

jcfjcf45200_1-1670246768625.png

I didn't update the µIO-Stick, because previously, I updated an other µIO-Stick with the firmware available in the BSL-TOOLS_2022-02-26 package (bsl_1.1.867) but it seems it bricked  (now Windows can't recognize it). Then I bought a new µIO-Stick. It seems the current firmware of my new µIO-Stick  is 3.0 (verified with Config Wizzard).

jcfjcf45200_2-1670250365360.png

Then when I push on the "Connect" button, nothing happen. The status stay disconnected and I can't update my target.

I don't know if it is normal, but the red led (ERR) in the µIO-Stick is turned on and the orange led (ACT) is blinking.

1670245309662.jpg

 

Someone has an idea where does come from my problem?

Thanks.

 

0 Likes
1 Solution
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @jcfjcf45200,

Please refer to the Re: uIO stick = unkown device after FW update  for the solution.

Thank you

Best Regards

Raj Chaudhari

View solution in original post

0 Likes
5 Replies
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @jcfjcf45200,

Could you please follow the steps mentioned below to debug the issue:

1) Confirm if the orientation of the chip inserted in the TQFP socket is correct.

2) Please check if you are not missing any steps mentioned in the section 4 FastLIN BSL support of the μIO-Stick user guide.

Please let us know if you need further support.

Thank you

Best Regards

Raj Chaudhari

0 Likes

Hello, 

the orientation of the µc seems ok (upper left). The only missing step in the section 4 it is the upgrade of the µIO-stick, I didn't it because the last time I upgraded a µIO-stick, it was bricked. I don't want brick my µIO-stick one more time. But if it is necessary, I will upgrade it.

0 Likes

I updated the µIO-stick with config Wizzard, it seems ok, windows recognize it. The red led (ERR) is turn off now and the orange led (ACT) is blinking. But I can't update the target, it stay "disconnected"

1670926648290.jpg

0 Likes
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @jcfjcf45200,

It is required to program the uIO stick by executing the UpdateBSL.cmd file. After this please try using the following attached configuration file to establish the connection.

Thank you

Best Regards

Raj Chaudhari

0 Likes
Raj_JC
Moderator
Moderator
Moderator
250 replies posted First question asked 100 solutions authored

Hi @jcfjcf45200,

Please refer to the Re: uIO stick = unkown device after FW update  for the solution.

Thank you

Best Regards

Raj Chaudhari

0 Likes