Announcements

Register now for the most anticipated Asia Pacific Power Seminar 2022

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

MOSFET (Si/SiC) Forum Discussions

Not applicable
We need sincere helps from this website.

The IR3475MTRPBF is selected in my design as attached configuration.

At the first, the load is not connected to IR3475MTRPBF and EN pin is connected to +5V, VCC pin is connected to +5V and FCCM pin is connectedf to +5V as well.

The weired thing is IR3475MTRPBF lost +3.3V output after few seconds.

We have checked 3VCBP pin, it is always +3.4V around. VCC, FCCM and EN are connected to +5V solidly.

Please let me know , where is wrong in my design configuration for IR3475MTRPBF.

Many thanks.

David.

2867.attach
0 Likes
1 Solution
User270
Level 5
5 solutions authored First solution authored
Level 5
I found for the required 2A output current the Rset value as 1368Ohms. The power good pul-up resistor is connected to the output voltage 3.3V, I suggest to use controller's power supply. I did not check the values for COUT, CBOOT and the inductivity.

View solution in original post

0 Likes
2 Replies
User270
Level 5
5 solutions authored First solution authored
Level 5
I found for the required 2A output current the Rset value as 1368Ohms. The power good pul-up resistor is connected to the output voltage 3.3V, I suggest to use controller's power supply. I did not check the values for COUT, CBOOT and the inductivity.
0 Likes
Not applicable
Dear Forix,

Many thanks for your generous help.

I have one question regarding to Rset: Is there going to be the problem for IR3475MTRPBF to drop down to +1V as current situation, if Rset is set to 6K8 instead of 1.368K?

Because the current consumption is estimated, it cover a wide range from 2A to 10A, I only use 6K8 for Rset.

It is so frustrated.

Any helps are appreciated.

David.
0 Likes