Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

MOSFET (Si/SiC) Forum Discussions

User19428
Level 1
First question asked
Level 1
Dear Infineon Community,

Could it be that there is an error in the thermal part of the SiC MOSFET models?

When simulating for several tens of seconds the current out of the Tcase pin approaches ten times the power dissipation (Idrain*Vdrain-source) in the device, while a value equal to the power dissipation is expected.
The temperature difference between Tj and Tcase also reflects a power of ten times the real power dissipation.

4220.attach4221.attach

Please see the attached simulation circuit and results graph as png files, since Simetrix .sxsch files are not allowed.

SiC models from other brands do show the proper thermal response in this simulation circuit.

So I am either overlooking something obvious or there is something not fully correct in the IMW120R060M1H simulation model.

Best regards,

Gerhard
0 Likes
1 Solution
modelmaker
Employee
First solution authored
Employee
Dear Gerhard,

thank you for reporting this issue. We have checked this and could confirm your observation. Indeed there is an error in the calculation formula of the dissipated losses and therefore also in the thermal response. We have fixed this and will upload the latest corrected version to the website within the next few days.

In the meantime as a quick fix, you can also open the .lib file in a text editor and replace the text in line 373:

R18 0 N7 10

with

R18 0 N7 1


This should solve the problem.


Best regards,

Paul

View solution in original post

0 Likes
1 Reply
modelmaker
Employee
First solution authored
Employee
Dear Gerhard,

thank you for reporting this issue. We have checked this and could confirm your observation. Indeed there is an error in the calculation formula of the dissipated losses and therefore also in the thermal response. We have fixed this and will upload the latest corrected version to the website within the next few days.

In the meantime as a quick fix, you can also open the .lib file in a text editor and replace the text in line 373:

R18 0 N7 10

with

R18 0 N7 1


This should solve the problem.


Best regards,

Paul
0 Likes