Announcements

Live Webinar: Solving the challenges in xEV power conversions | March 7 @9am & 5pm CET. Register now!

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
LMH
Level 1
Level 1
5 sign-ins First reply posted First question asked

Hello,

I'm trying to simulate transient electrical and temperature behavior  of an IMW120R014M1H SiC Mosfet

My company use Orcad PSpice V17.2.2016

I downloaded the model bank "Infineon-CoolSiC_silicon_carbide_MOSFET_1200V_SPICE-SimulationModels-v01_03-EN",  then added the library "imw-imza120rxxxm1h_7-40mohm" to my design.

I draw a part and tied the 5 pins to the model pins.

 

When I launch simulation, PSpice made 3 errors that are "ERROR(ORPSIM-16366): Line too long. Limit is 132 characters."

(See Error132CharLong joined)

 

I tried to modify the faulty lines according to this cadence forum :

https://community.cadence.com/cadence_technology_forums/f/functional-verification/31532/simulation-e...

Lines modified are :

in SUBCKT Z0022 :  

.FUNC N02Y0(N02RN,N02RY,N02SE)={N02V8(N02RN,N02RY,N02SE)*((TANH((N02RY/(N02V8(N02RN,N02RY,N02SE)*
+N02VU(N02RN,N02RY,N02SE)))**(1/N02YH(N02RN,N02SE))))**N02YH(N02RN,N02SE))}

G01NW N03D6 N01U5 VALUE={N02NS*IF(V(N03D6,N01U5)>0.0,N02ZJ(V(TJ,0),V(N03D6,N01U5),V(N01TK,N01U5)),
+N03BE(V(TJ,0),V(N03D6,N01U5),V(N01TK,N01U5)))}

and in SUBCKT Z002I :

G01PF N01TE N01U5 VALUE={N02NS*IF(V(N01TK,N01U5)>3,0,IF(V(N01TE,N01U5)>-N03F7(V(TJ,0),V(N01TK,N01U5)),
+0,-N03D7(V(N01TE,N01U5),V(TJ,0),V(N01TK,N01U5))))}

 

Now, with the modified SUBCKTs, I have another ERROR, wich is : "ERROR(ORPSIM-15167): Undefined parameter: N02PE."

(see Error_LibModified)

 

Can someone help me ?

Regards

 

 

0 Likes
1 Solution
Santhoshkumar
Moderator
Moderator
Moderator
25 solutions authored First like given 50 replies posted

Dear @LMH 
Greetings from Infineon
Good day!!

We have tried to solve the error in Pspice in all the ways possible but the model(L3 type) is having a compatibility issues with LT-spice and Pspice, can you please consider performing  the simulation using the simetrix software for better results. As the model tested and validated in the same platform.
You can do most of the measurements and simulations in the simetrix in the same way as the LT-spice and P-spice. 
It is a licensed software. However there is a trail version with certain limitations one such is restricting up to 140 analog nodes (internal and external )
please refer the below link for more details
https://www.simetrix.co.uk/downloads/download-elements.html

Kindly let me know if you have any further queries.

Best regards,
Santhosh Kumar

View solution in original post

0 Likes
4 Replies
Santhoshkumar
Moderator
Moderator
Moderator
25 solutions authored First like given 50 replies posted

Dear @LMH ,
Greetings from Infineon,
Thanks for posting your query in Infineon Community!

We are working on your question.
Please wait for sometime.
Meanwhile can you please share your simulation model (basic test circuit, where you are encountering the error) in order to help you faster.

Best regards!
Santhosh Kumar

0 Likes
LMH
Level 1
Level 1
5 sign-ins First reply posted First question asked

Dear @Santhoshkumar ,

Thanks for the reply.

Attached is a scrennshot of my circuit, which is quite basic. you can see the netlist part in previous errors screenshots.

I hope this will help...

best regards,

0 Likes
LMH
Level 1
Level 1
5 sign-ins First reply posted First question asked

UPDATE :

it seems that PSpice need to have each parameter declared in each SUBCKT :

"N02PE" and its subparameter "N02SJ,  N02SV, N02TG and N02UA" are declared in Z0022 SUBCKT but not in Z002I, where N02PE is called.

adding the N02PE function and its parameter from Z0022 into Z002I solve the error, but I do not know if its accurate for the global model...

Note that i try the model with  LTSpice, and this error does not occurs with it (nor the 132char long issue...)

now, I have another problem with N03DE node in Z0022 subckt.

Both LTSpice and PSpice send me an error on this node which seems to be floating. Pspice send me another error on TJ node wich seems to be floating too in Z0022.

If someone understand how to make this model work with PSpice...

 

 

0 Likes
Santhoshkumar
Moderator
Moderator
Moderator
25 solutions authored First like given 50 replies posted

Dear @LMH 
Greetings from Infineon
Good day!!

We have tried to solve the error in Pspice in all the ways possible but the model(L3 type) is having a compatibility issues with LT-spice and Pspice, can you please consider performing  the simulation using the simetrix software for better results. As the model tested and validated in the same platform.
You can do most of the measurements and simulations in the simetrix in the same way as the LT-spice and P-spice. 
It is a licensed software. However there is a trail version with certain limitations one such is restricting up to 140 analog nodes (internal and external )
please refer the below link for more details
https://www.simetrix.co.uk/downloads/download-elements.html

Kindly let me know if you have any further queries.

Best regards,
Santhosh Kumar

0 Likes